Results 1 to 5 of 5

Thread: BioShock crashes on launch (Steam version)

  1. #1

    BioShock crashes on launch (Steam version)

    BioShock keeps crashing whenever I try to play it. It gets past the "preparing to launch", shows the BioShock image on the desktop, but before the game actually launches I get hit with a "Bioshock.exe has stopped working, Windows is looking for a solution" message.

    I originally put BioShock on the computer via an ethernet cable from a the steamapps common folder of a computer that already had the full game installed (and ran it with my account). I transferred a bunch of other games (Mass Effect series, TESIV, Alpha Protocol, etc) and they all work. After BioShock failed, I uninstalled it and reinstalled it via internet download. Same problem. I uninstalled it again, this time going into the registry with regedit to remove any trace of it. Reinstalled, same problem.

    My computer's specs are as follows:

    Windows 7 Ultimate 64-bit
    EVGA Nvidia Geforce 9800 GT 512 MB
    Graphics Driver version: 8.17.12.6099
    Direct X: 10 and 9.0c installed
    Sound Hardware ID: HDAUDIO\FUNC_01&VEN_8384&DEV_7618&SUBSYS_102801DB& REV_1002
    Sound Driver Version: 6.01.7600.16385
    Intel Core 2 Duo E6600 2.4 GHz
    4 GB DDR2 RAM

    Can anyone suggest something that might help?

  2. #2
    Join Date
    Sep 2010
    Location
    Support
    Posts
    1,792
    Bring up the Start menu and right-click on Computer, selecting Manage.

    Drop down the menu for Event Viewer, then Windows Logs, then highlight Application.

    Select a corresponding event from the list and post the details in here

  3. #3
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-02-01T18:13:27.000000000Z" />
    <EventRecordID>3908</EventRecordID>
    <Channel>Application</Channel>
    <Computer>J_Bolt-desktop</Computer>
    <Security />
    </System>
    - <EventData>
    <Data>bioshock.exe</Data>
    <Data>1.0.0.0</Data>
    <Data>474f5a3a</Data>
    <Data>OLEAUT32.dll</Data>
    <Data>6.1.7600.16567</Data>
    <Data>4bbc2f3d</Data>
    <Data>c0000005</Data>
    <Data>00004971</Data>
    <Data>5b4</Data>
    <Data>01cbc23bb4574425</Data>
    <Data>d:\steam\steamapps\common\bioshock\Builds\Re lease\bioshock.exe</Data>
    <Data>C:\Windows\syswow64\OLEAUT32.dll</Data>
    <Data>f68f9258-2e2e-11e0-ad74-001676c266d7</Data>
    </EventData>
    </Event>

  4. #4
    Join Date
    Sep 2010
    Location
    Support
    Posts
    1,792
    Quote Originally Posted by SSV Enterprise View Post
    <Data>C:\Windows\syswow64\OLEAUT32.dll</Data>
    Could be nothing, but that file is apparently related to C++, so updating that would be a good route to go down...

    Visual Runtimes:
    http://www.microsoft.com/downloads/d...DisplayLang=en
    Visual Runtimes sp1:
    http://www.microsoft.com/downloads/d...DisplayLang=en

  5. #5
    Ok, I just found a really weird solution to this. It launches if sound is disabled or...if a microphone is plugged in.

    o_O Not really sure what plugging a microphone in does, but it works!
    Last edited by SSV Enterprise; 08-08-2011 at 05:49 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •