Results 1 to 4 of 4

Thread: Game suddenly stopped working

  1. #1
    Join Date
    Apr 2011
    Posts
    3

    Game suddenly stopped working

    So I bought Civ V over the weekend and played it with no problems for two days. Then I try to start it up today and it will get as far as the 2K logo before crashing to desktop. My computer meets the minimum specs and as I said it was running just fine previously. So I don't know what the problem is. I disabled the starting cinema and it still crashes, I deleted the civ 5 folder in the My games folder and it got two steps further than the 2k logo and crashed again.

    Can someone help me out? I don't get a lot of money for games and I chose to buy this one this month and it's turning out not so well.

  2. #2
    Join Date
    Jan 2011
    Posts
    888
    Have you tried to verify the game files? Right-click the game's name in your Steam library and choose Properties, then go to the Local Files tab and click "Verify Integrity of the Game Cache". There's one file that will always fail verification and be replaced, so don't worry when you get that message.

  3. #3
    Join Date
    Apr 2011
    Posts
    3
    Thanks! That fixed it! I wonder what went wrong in it's guts that made it suddenly stop working like that?

  4. #4
    Join Date
    Jan 2011
    Posts
    888
    There was probably a Windows automatic update that changed just the right (or wrong) thing to make Steam want to regenerate Civ V's executable. (Steam can generate game files that are specific to your account.)

    Whether this is the case or not I can't confirm, but it was my suspicion because Tuesdays are patch days for Windows, and you played over the weekend and then not again until yesterday - during which time there was a Windows update.

    I'm happy to have been of assistance. Enjoy the game.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •