Results 1 to 9 of 9

Thread: bioshock keeps crashing

  1. #1
    Join Date
    Sep 2007
    Posts
    5

    bioshock keeps crashing

    While playing the game on pc i get random crashes where an error comes up saying that bioshock has stoped working this is really pissing me off. From what i have read on the forms a loot of people have had the same problem. also i have not seen a response from and game technical support that is of any help yet. I hope 2k or who ever it is who makes the game will put the time in to fix the game before it all goes to poo it will be a shame becouse it is a great game. But atm i am not enjoying it due to having to repet so much of it due to crashes hope u get back to all of us asap before i have to thke the game back for a refund my system is
    ------------------
    System Information
    ------------------
    Time of this report: 9/6/2007, 17:47:52

    Operating System: Windows Vista™ Home Premium (6.0, Build 6000) (6000.vista_gdr.070627-1500)
    Language: English (Regional Setting: English)
    System Manufacturer: HP-Pavilion
    System Model: RZ555AA-ABG m8075a
    BIOS: Phoenix - AwardBIOS v6.00PG
    Processor: Intel(R) Pentium(R) D CPU 3.20GHz (2 CPUs), ~3.2GHz
    Memory: 2046MB RAM
    Page File: 1105MB used, 3202MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 10
    DX Setup Parameters: Not found
    DxDiag Version: 6.00.6000.16386 32bit Unicode

    ------------
    ---------------
    Display Devices
    ---------------
    Card name: NVIDIA GeForce 7500 LE
    Manufacturer: NVIDIA
    Chip type: GeForce 7500 LE
    DAC type: Integrated RAMDAC
    Device Key: Enum\PCI\VEN_10DE&DEV_01DD&SUBSYS_034B1043&REV_A1
    Display Memory: 1017 MB
    Dedicated Memory: 249 MB
    Shared Memory: 767 MB
    Current Mode: 1680 x 1050 (32 bit) (60Hz)
    Monitor: SyncMaster 226BW(Digital)
    Driver Name: nvd3dum.dll,nvwgf2um.dll
    Driver Version: 7.15.0011.6222 (English)
    DDI Version: 9Ex
    Sound Devices
    -------------
    Description: Speakers (Realtek High Definition Audio)
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A50& REV_1000
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHDA.sys
    Driver Version: 6.00.0001.5361 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 1/19/2007 04:56:00, 1729632 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    6386

  2. #2
    Join Date
    Aug 2007
    Posts
    965
    get the 163.44 video drivers

  3. #3
    Join Date
    Aug 2007
    Location
    Lodi, CA, USA
    Posts
    94
    Turning off High Detail Shaders and perhaps some of the other High Detail settings has been the solution most often suggested for this problem, especially for users with nVIDIA 7xxx-series graphics cards.

    Perhaps no one from 2K Tech Support has personally suggested this (although I have a feeling they have), but it's been suggested in literally hundreds of other posts by other users.

    Good luck!

  4. #4
    Join Date
    Aug 2007
    Location
    Lodi, CA, USA
    Posts
    94
    And, as your running a mobile graphics chip on a laptop, look for the laptop version of the 163.44 drivers...Google is you friend.

  5. #5
    Join Date
    Aug 2007
    Posts
    965
    Quote Originally Posted by reholli View Post
    And, as your running a mobile graphics chip on a laptop, look for the laptop version of the 163.44 drivers...Google is you friend.
    yes and if you had used google you would know that his pc is a HP desktop media center

  6. #6
    Join Date
    Sep 2007
    Posts
    1
    i am having the same problem its quiteannoying. i have a hp pavillion as well
    2.4cpu speed 3g memory 500g hardrive gforce 7350 le. the games crashes like every 15 minutes which sux bigtime cuz i spent 2k dollars on a computer so i could play this game and the crap doesnt work ..o and i already have all the settings on low including resolution so that helps it run smoother but doesnt prevent the crashes and i have latest drivers on everything.

  7. #7
    Join Date
    Aug 2007
    Posts
    299
    Rhyths you could try the update for the Realtek drivers from the link below.
    Realtek HDR drivers

    There is also some hotfixes for Vista

  8. #8
    Join Date
    Sep 2007
    Posts
    7

  9. #9
    Join Date
    Aug 2007
    Location
    England
    Posts
    59
    Like suggested above you should try updating your grafic drivers.
    Please make sure that while updating those kind of drivers to ALWAYS uninstall any previously installed grafic drivers or it may lead to issues.

    You may also want to try to add the game to the windows DEP exception list.
    This has helped people in other games not sure if it is working for this issue or not yet.

    1.) Open "Control Panel"
    2.) Click on "System and Maintenance"
    3.) Click on "System"
    4.) On the left side click on "Advanced System Settings"
    you will be asked for permission to continue, click continue
    5.) Click on the Advanced tab and then on "Settings" in the Performance area
    6.) Click on the DEP (Data Execution Prevention) tab
    7.) Put a tick in the little circle next to "Turn on DEP for all programs and services
    except those I select" and click on the "ADD" button and
    browse for and click on the .exe file for bioshock or
    any other App you would like to add then click "Open" now click "Apply" then "OK"
    and close all open windows and your done. (you may have to reboot your system for it to take effect)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •