Results 1 to 5 of 5

Thread: Bioshock 2 fps problem

  1. #1
    Join Date
    Feb 2012
    Posts
    1

    Bioshock 2 fps problem

    Hello,
    My system is
    MB : ASUS STRIKER II EXTREME (Socket 775)
    CPU : Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    RAM : Corsair Vengeance 2x4096 @ 1600Mhz 7-8-7-20
    GPU : Gigabyte NVIDIA GeForce GTX 560 Ti 1024MB
    GPU Driver : 295.73
    OS : Windows 7 64bit

    I tried playing bioshock 2 for the first time yesterday (on the highest settings) and i got 3-4 fps. I noticed that the CPU usage was at 98-100%.
    Today I lowered all the setting at their minimum values and i still get 3-4 fps with the CPU usage still at 98-100% which makes the game unplayable.
    I always check the recommended system requirements before bying a game and my PC stats are a lot higher than the recommended values. I beleieve I should be able to play the game at full settings without any problems, since I am able to play games like battlefield 3.
    I tried some things i read on the forums, like setting the maximum prerendered frames to zero, but no change. I still get max 4 frames.
    How can i make this game playable?

  2. #2
    Join Date
    Mar 2012
    Posts
    1
    I have a similar setup and I cannot get more than a few frames per second. I've also tried putting all the settings on low, but it seems like it somehow makes it worse. My computer can run the first Bioshock flawlessly and it is very frustrating that Bioshock 2 will not run properly. Someone please help!

  3. #3
    Join Date
    Mar 2012
    Posts
    2
    It has something to do with GFWL. I disabled it once right after I bought it (a year or so ago? a steam sale, whenever it was) after having this very issue, and was able to play it at insane FPS. As soon as GFWL is turned back on, FPS back to zilch. Problem is that you can't save your game unless you're connected to GFWL, so the game is, for all intents and purposes, unplayable. I don't expect 2K or Microsoft to do anything about it - it's past that sort of support as far as age. Steam won't do anything about it, since it's a 3rd party (i.e., not Steamworks) game.

    I left it installed in the remote hope that there would be a patch, but I don't see it happening. Glad I only spent a few bucks on it.

  4. #4
    Join Date
    Mar 2012
    Posts
    2
    well, I'll be.... Haven't tried it in a while, so did some searching after I made that last post. This fixed it for me:
    http://forums.steampowered.com/forum....php?t=1971455

    Turn off ambient occlusion. I don't know if this will work for AMD/ATI cards, but it sure as heck fixed it for me. Not sure why it seemed 'better' with GFWL turned off (tested that out again before finding the solution linked above), but it definitely was not fixed with GFWL off (just less sluggish, but still a little jerky).

    • In the nVidia Control Panel, under 3D Settings > Manage 3D Settings, click the "Program Settings" tab in the right pane.
    • Under "1. Select a program to customize", scroll down and find Bioshock 2. If it's not there (mine wasn't), add it to the list.
    • To add the program in the nvidia control panel, drill down to the game .exe, which isn't in the base Bioshock2 folder. My path was:
      C:\Program Files (x86)\Steam\steamapps\common\bioshock 2\SP\Builds\Binaries\Bioshock2.exe
    • Under "2. Specify the settings for this program", change the setting of the feature named "Ambient Occlusion" to "Off"
    • Click the "Apply" button.

    Haven't tried multiplayer to see if it works, too, but it might. If the nvidia control panel looks at executable name and not path, it should work for the multiplayer executable as well, since they both have the same name, just a different path. If it doesn't work for multiplayer, just follow the directions above and instead of "SP" in the path, drill down under "MP" (SP = single player, MP = multiplayer).

    ETA my specs:
    MSI X58A-GD45 mobo
    i7-960 (LGA1366)
    6GB memory (triple channel mode)
    evga 560ti (crysis 2 edition)
    WDC Black 1TB HDD
    OCZ 700W PSU
    Windows 7 Home Premium 64-bit

    Good luck, hope this helps.

  5. #5
    Join Date
    Apr 2012
    Posts
    1

    Talking

    Quote Originally Posted by count_dingo View Post
    well, I'll be.... Haven't tried it in a while, so did some searching after I made that last post. This fixed it for me:
    http://forums.steampowered.com/forum....php?t=1971455

    Turn off ambient occlusion. I don't know if this will work for AMD/ATI cards, but it sure as heck fixed it for me. Not sure why it seemed 'better' with GFWL turned off (tested that out again before finding the solution linked above), but it definitely was not fixed with GFWL off (just less sluggish, but still a little jerky).

    • In the nVidia Control Panel, under 3D Settings > Manage 3D Settings, click the "Program Settings" tab in the right pane.
    • Under "1. Select a program to customize", scroll down and find Bioshock 2. If it's not there (mine wasn't), add it to the list.
    • To add the program in the nvidia control panel, drill down to the game .exe, which isn't in the base Bioshock2 folder. My path was:
      C:\Program Files (x86)\Steam\steamapps\common\bioshock 2\SP\Builds\Binaries\Bioshock2.exe
    • Under "2. Specify the settings for this program", change the setting of the feature named "Ambient Occlusion" to "Off"
    • Click the "Apply" button.

    Haven't tried multiplayer to see if it works, too, but it might. If the nvidia control panel looks at executable name and not path, it should work for the multiplayer executable as well, since they both have the same name, just a different path. If it doesn't work for multiplayer, just follow the directions above and instead of "SP" in the path, drill down under "MP" (SP = single player, MP = multiplayer).

    ETA my specs:
    MSI X58A-GD45 mobo
    i7-960 (LGA1366)
    6GB memory (triple channel mode)
    evga 560ti (crysis 2 edition)
    WDC Black 1TB HDD
    OCZ 700W PSU
    Windows 7 Home Premium 64-bit

    Good luck, hope this helps.
    IT WORKS ! THANKS ! I made an accout just to thank you xD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •