Results 1 to 22 of 22

Thread: Rendered upside down in 5760 x 1080 Eyefinity setup

  1. #1
    Join Date
    Sep 2010
    Posts
    26

    Rendered upside down in 5760 x 1080 Eyefinity setup

    So at first I thought there was some interesting camera work going on to disorient me by showing the scene upside down. Then as I realized it wasn't shifting to right side up we have a problem here. Shifting the game to 1920 x 1080 renders correctly, just can't use my 3 monitors evidently without standing on my head.

    This is on Windows 7 64-bit, AMD Radeon HD 6970, i7-2600K, latest drivers, etc.

  2. #2
    Join Date
    Jun 2012
    Location
    Norway
    Posts
    240
    Don't you just absolutely adore the Unreal Engine codebase?

    I.e., "Let's just use a range-lookup that throws away any superfluous numbers above "2048". And then automatically use the shortest side as the height of the screen when initialising the viewport! What could possibly go wrong!?".

  3. #3
    Join Date
    Sep 2010
    Posts
    26
    Well hopefully they get around to fixing it!

  4. #4
    Join Date
    Jun 2012
    Location
    Norway
    Posts
    240
    I don't think it involves a lot of work. But ..I'm guessing they would need to use a workaround somehow for Xcom's rendering engine specifically. So maybe write 2k, or "file" a specific bug-report..? If someone knows what they need to do to fix it and picks it up, it's the kind of thing that might be fixed.. even if it probably affects very few people.

  5. #5
    Join Date
    Sep 2010
    Posts
    26
    Yeah I know 3 monitor support is never high in priority for game dev teams, but it looks like the game runs just fine otherwise. If it's just a small tweak they have to make to keep me from standing on my head that would be awesome!

  6. #6
    Join Date
    Sep 2012
    Posts
    159


    Have a nice day

  7. #7
    Join Date
    Sep 2010
    Posts
    26
    I'll give that a shot to see if the UI becomes upside down then. Although I suppose I could handle that maybe... Will report back in a couple hours!

  8. #8
    Join Date
    Sep 2012
    Posts
    159
    14 hours have passed. Does that mean it worked and you cant pull yourself away from the game?

  9. #9
    Join Date
    Oct 2012
    Posts
    2
    Flipping the displays will not fix it unfortunately, as the FoV is inverted. The UI renders correctly, but everything else is upside down.
    Setting Inverted on the monitors produces the opposite effect, graphics are right side up, but UI is inverted, so all the text is upside down and the menus are on the wrong side. I'm downloading the new patch atm so i'll see if they fixed it yet.
    Here's hoping... atm i have to play 1920x1080 if i want to play
    Here's an image someone posted in another thread about the same issue with the demo..



    Just tested after the patch and it's the same thing
    Last edited by Vladislaus; 10-11-2012 at 07:29 PM.

  10. #10
    Join Date
    Sep 2012
    Posts
    159
    k, this is definatly one for firaxis to fix then.

  11. #11
    Join Date
    Sep 2010
    Posts
    26
    I don't have the option to flip the orientation like in your screenshot. I could probably handle the upside down UI. Not that that's a good "fix" really, but would have been ok until a real fix is in.

    Of course after the patch my video is extremely choppy which is a whole separate issue. *sigh*

  12. #12
    Join Date
    Jul 2011
    Posts
    7
    Quote Originally Posted by sschrupp View Post
    I don't have the option to flip the orientation like in your screenshot. I could probably handle the upside down UI. Not that that's a good "fix" really, but would have been ok until a real fix is in.

    Of course after the patch my video is extremely choppy which is a whole separate issue. *sigh*

    Same trouble here, first i had the opinion that the view was correct but then i realized that it was a bug showing in every resolution beyond 1x HD (eyefinity)
    I am wondering if NVidia-setups have the same problems?

    I am playing xcom on an 2600k, 16gb ram and my HD 7990 and its the first game i had this issue.

  13. #13
    Join Date
    Oct 2012
    Posts
    2
    Quote Originally Posted by TvA View Post
    Same trouble here, first i had the opinion that the view was correct but then i realized that it was a bug showing in every resolution beyond 1x HD (eyefinity)
    I am wondering if NVidia-setups have the same problems?

    I am playing xcom on an 2600k, 16gb ram and my HD 7990 and its the first game i had this issue.
    I'm running it on 2x gtx 670 and I have the same problem, I have to keep playing the game on 1920x1080 and turning off the 2 other monitors.

    i7 3930k, 32gig ram, 2x gtx 670.

  14. #14
    Join Date
    Jul 2011
    Posts
    7
    Quote Originally Posted by drekx View Post
    I'm running it on 2x gtx 670 and I have the same problem, I have to keep playing the game on 1920x1080 and turning off the 2 other monitors.

    i7 3930k, 32gig ram, 2x gtx 670.
    Thx for the information,
    at least its good to hear thats this is not only an ati-problem.

  15. #15
    Join Date
    Sep 2010
    Posts
    26
    So does anyone else feel that the main menu screen is particularly creepy when it's rendering upside down? It really feels like maybe you're a person that was in the car that wrecked and that alien skittering around is going to come get you while your legs are pinned down or something.. lol. So my first view of this game was "Oh wow, that's freaky. How awesome! Can't wait to play this!"

    How disheartening when I realized it was just the game not rendering correctly... hehe. Still love the game though. Just hope they can eventually get to this issue some day after they take care of some of the more "important" bugs. *cough*coverLOSberserkerlag*cough*

  16. #16
    Join Date
    Oct 2012
    Posts
    3
    Would be pleased if Firaxis fix the multi monitor problem. Not going to play the game until it is.

  17. #17
    Join Date
    Oct 2012
    Posts
    2
    I've been trying to enjoy the ps3 version until this is fixed, for now multi-monitor it is still inverted

  18. #18
    Join Date
    Oct 2012
    Posts
    362
    Weird, I have a dual monitor setup, twice 1920 x 1080, and it is rendering correctly for me. NVidia 560 GTX as (single) videocard, playing the game on my left monitor. The only annoyance that I have is that when I want to do something on the other screen, the game minimizes to the tray. However, pure windowed mode is not an option, due to V-sync issues.

  19. #19
    Join Date
    Sep 2010
    Posts
    26
    Maurice76, the video is only rendered upside down when displayed in the extended resolutions that cover all 3 monitors at once. It displays correctly when at 1920 x 1080 on one (or copies on all 3) monitor(s). I haven't tried disconnecting one monitor to see if it's upside down when stretched across two monitors, but having the monitor bezels in the middle of my view would drive me crazy anyhow.. lol.

  20. #20
    Join Date
    Jun 2011
    Posts
    2
    I get the same thing in Eyefinity. UI is fine and even centered but everything else is upside down. Also the briefing screen at the start (where you click "launch mission") is stretched.
    Specs are (if it even will get noticed by Firaxis).
    Core i7 930 oc'd
    2x HD 7970
    6 gig 2000mhz CL9 Ram
    Asus Xonar DX sound card
    X58-UD3R rev 2.0
    Win 7 64bit. Other specs should be irrelevant.

  21. #21
    Join Date
    Jan 2013
    Posts
    1
    After a lot of searching around for a fix, I started messing with some configuration files and was able to come up with something. In "SteamApps \ common \ XCom-Enemy-Unknown \ XComGame \ Config" you will find a "Default Camera" file. Edit that file to look like this:

    [Engine.Camera]
    DefaultAspectRatio=5.334
    bConstrainAspectRatio=True
    ConstrainedAspectRatio=5.334

    Bascially, change "False" to "True" and change the aspect ratio from the default 1.778 to whatever aspect ration you happen to be using, so for 16:3 it would be 5.334.

    Note that this is not a perfect fix and I will continue to find something better, this is just what I came up with in 2 minutes of opening the game for the first time. Your camera seems to be a bit zoomed in but at least it's not upside down.

  22. #22
    Join Date
    Jul 2011
    Posts
    7
    Quote Originally Posted by kylall77 View Post
    After a lot of searching around for a fix, I started messing with some configuration files and was able to come up with something. In "SteamApps \ common \ XCom-Enemy-Unknown \ XComGame \ Config" you will find a "Default Camera" file. Edit that file to look like this:

    [Engine.Camera]
    DefaultAspectRatio=5.334
    bConstrainAspectRatio=True
    ConstrainedAspectRatio=5.334

    Bascially, change "False" to "True" and change the aspect ratio from the default 1.778 to whatever aspect ration you happen to be using, so for 16:3 it would be 5.334.

    Note that this is not a perfect fix and I will continue to find something better, this is just what I came up with in 2 minutes of opening the game for the first time. Your camera seems to be a bit zoomed in but at least it's not upside down.
    THIS
    works perfectly.
    Thx a very lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •