Results 1 to 37 of 37

Thread: S.H.I.V. Unable to Deploy

  1. #1
    Join Date
    Oct 2012
    Posts
    2

    S.H.I.V. Unable to Deploy

    I'm having a lot of issues with SHIVs. The first one I made (alloy shiv) worked fine, but got destroyed. Then I made a second normal one and for some reason it seemed to be completely unable to fire, it could only move. So I just used it as a decoy to draw fire. Obviously it died. Now I've made a third normal SHIV and it won't even let me deploy it to a mission. It's not damaged or anything since it's never gone on a mission.

    Here's a screenshot: http://cloud.steampowered.com/ugc/90...21DBF9B9CF040/

    When I select it, it just makes the buzzing sound you get when you try to perform an action you can't perform. It's kind of annoying because they're very useful tools when functioning.

    Edit: Also, the SHIV has no model when you select it in the barracks. Just empty space.

    Another edit: Dismantled it and made another one that worked properly. Decided to make 2 so I'd have backups since they're fairly effective for their price... both of them are doing the same thing - can't put them in my squad and have no model when selected from the barracks.
    Last edited by Endyo; 10-10-2012 at 07:27 PM.

  2. #2
    Join Date
    Sep 2012
    Location
    NL
    Posts
    51
    Had the same problem. Had a normal shiv worked fine got busted up, made new one but it had no gun (WTF), made hover shiv, worked like a charm and save my ass many times. Made a suicide run on a sect.commander, will be missed. Build new one, cant deploy.....
    game is fun, but broken, bad show ppl

  3. #3
    Join Date
    Oct 2012
    Posts
    3
    Same here. Shiv fine, Alloy shiv, no gun options whatsoever.

  4. #4
    Join Date
    Oct 2012
    Location
    29 Palms, CA
    Posts
    10
    I have another problem with the Hover SHIV. It can be deployed but has no weapon and can't activate the flight mode. Xbox version.

  5. #5
    Join Date
    Sep 2012
    Posts
    104
    Quote Originally Posted by Ceepo View Post
    I have another problem with the Hover SHIV. It can be deployed but has no weapon and can't activate the flight mode. Xbox version.
    Same problem.

    And same problem as OP. Sometimes it works, sometimes doesn't sometimes half way.

  6. #6
    Join Date
    Oct 2012
    Posts
    1
    Mines better, have a alloy shiv that should have a laser cannon on it, i am able to get it into the squad but with no picture in the squad line up.

    I mission the shiv looks like a normal solider with an assault rifle. The Unit has shiv level health and moves and fights like a shiv, but only does assault rifle damage to units.

    Best part is that since there no cover i put the shiv in the middle of no where, and when attack it has a tendancy to turn and flee in panic.

    Humanoid, panicking tanks... i don't remember authorizing that upgrade.

    Oh, and my backup shiv is not selectable at all.

  7. #7
    Similar problem here; my first SHIV got destroyed and made two more. One of which I cannot add to my squad during mission selection but the other works fine. The one that doesn't work makes the error buzz noise when trying to add it to my squad and going to the barracks reveal an empty spot where the SHIV should be. This is the PC version.

  8. #8
    Join Date
    Oct 2012
    Location
    29 Palms, CA
    Posts
    10
    Interesting update on my broken Hover SHIV. When I built it and it had no weapon, it was supposed to be a laser cannon. When I upgraded to plasma in the foundry the Hover SHIV was fixed with the new plasma weapon.

  9. #9
    Similar SHIV problems here. Built 2, first one worked but got destroyed. I was unable to deploy the second one, so I scrapped it and built 2 more. Again, I was unable to deploy the first SHIV on the list, but was able to deploy the second.

    My theory is that the first Active SHIV on your list (after your first mission deploying SHIVs) will be bugged, so always have 2 or 3 on hand so you don't have to use the 1st (bugged) SHIV.

    Will test that theory more later.

  10. #10
    Join Date
    Aug 2012
    Posts
    2
    Same issues here but also had one where my SHIV turned into a headless female model after 1 mission. Was sad to see the humanoid version die.

  11. #11
    Join Date
    Oct 2012
    Posts
    2
    Will just add my voice to this chorus. First SHIV I built was an alloy SHIV with a standard minigun, and it worked fine. After it died I built another alloy SHIV with minigun and I am unable to deploy it on any missions...it appears in my barracks as Goliath-2, but I just get the error buzz noise when I try to click it.

    Then I recently built a hover shiv, and I was able to deploy it but just like Ceepo mine doesn't have a weapon (should be laser gun) and although there is a button for flight mode, I can't actually activate it. That's the only button it has. If I decide to invest in plasma I might see this fixes it and can report back, but since this is an ironman classic game I probably won't invest too much more in these buggy SHIVs unless I happen to have a lot of resources lying around.

    This is on PC. Great game otherwise, just hope these bugs get fixed! :-)

  12. #12
    Join Date
    Oct 2012
    Posts
    2

    invisible shiv

    I have the same issue, where my SHIV when viewed from the barracks does not display. My first Alloy Shiv worked fine. This is my 2nd alloy laser cannon shiv and the model does not render.

    Help!

  13. #13
    Join Date
    Oct 2012
    Posts
    14
    Same problem here. Xbox version.

  14. #14
    Join Date
    Oct 2012
    Posts
    4
    Same problem. Can't deploy Alloy SHIV, Hover SHIV has no weapon. PC Version.

  15. #15
    Join Date
    Oct 2012
    Posts
    2
    So I got to a point where upgrading to SHIV plasma wasn't too much of a risky cost, my hover SHIV did too then begin to work fully, including flight and weapon.

  16. I'm getting all the problems list in the thread.

    - Can't see the SHIV model itself in barracks.
    - Can't select SHIV to be in squad.
    - SHIV sometimes turns into a headless female rookie.
    - SHIV sometimes doesn't show up at all when on a map even when I was able to put it in a squad.

    *Newly built SHIV work fine after first mission, but after that 1 out of the four bugs occur.
    *This is still happening after the 10/11/2012 patch.

  17. #17
    Join Date
    Oct 2012
    Posts
    1
    Quote Originally Posted by Wandering Youth View Post
    I'm getting all the problems list in the thread.

    - Can't see the SHIV model itself in barracks.
    - Can't select SHIV to be in squad.
    - SHIV sometimes turns into a headless female rookie.
    - SHIV sometimes doesn't show up at all when on a map even when I was able to put it in a squad.

    *Newly built SHIV work fine after first mission, but after that 1 out of the four bugs occur.
    *This is still happening after the 10/11/2012 patch.
    Same FIX FOR THIS PLEASE!

  18. #18
    Join Date
    Oct 2012
    Posts
    1
    Me too, me too.The first one I made (alloy shiv) worked fine, but got destroyed. Then I made a second one (alloy again).... and I can't deploy it to a mission, can't put it in my squad and no model appears when selected from the barracks. PC version. Have not tried building a new one since the patch.

  19. #19
    Join Date
    Oct 2012
    Posts
    14
    Did this get cross-posted to the sticky bug thread? (Mmmm... sticky bug thread...)

  20. #20

    Same problem

    I am seeing this bug too:

    STR:

    1. build SHIV
    2. build hover SHIV
    3. hover SHIV gets destroyed
    4. Build Alloy SHIV
    5. Alloy SHIV deploys with no gun
    6. Alloy SHIV gets destroyed
    7. Build another SHIV
    8. The SHIV does not get displayed in the barracks or able to deploy

  21. #21
    Join Date
    Oct 2012
    Posts
    4
    Same problem on Xbox. 2nd Alloy S.H.I.V. will not deploy and get error buzz when trying to do so. Bummer, since I really could use it since my best squad just got destroyed on Ironman mode and I'm going on a Very Difficult terror mission with my highest ranking soldier being a Sgt. Not looking good. I need to do it though our I'll lose the US and I've already lost 5 countries. This bug could be my downfall.

  22. #22
    Join Date
    Aug 2012
    Posts
    251
    Same issues, SHIVs undeployable. Making them utterly broken. I just wish I could get refunded for all the resources I lost <.<

    Ah well, they were useful the three times they worked...

  23. #23
    Join Date
    Oct 2012
    Location
    Rhode Island, USA
    Posts
    102
    Another confirmed problem with the SHIV for me. I had the unselected, invisible, and headless female assault rifle versions. It was funny, the latter headless version, but it's gotta be fixed because it completely kills the immersion.

  24. #24
    Join Date
    Oct 2012
    Posts
    5
    Quote Originally Posted by lymphnodes0 View Post
    Will just add my voice to this chorus. First SHIV I built was an alloy SHIV with a standard minigun, and it worked fine. After it died I built another alloy SHIV with minigun and I am unable to deploy it on any missions...it appears in my barracks as Goliath-2, but I just get the error buzz noise when I try to click it.

    Then I recently built a hover shiv, and I was able to deploy it but just like Ceepo mine doesn't have a weapon (should be laser gun) and although there is a button for flight mode, I can't actually activate it. That's the only button it has. If I decide to invest in plasma I might see this fixes it and can report back, but since this is an ironman classic game I probably won't invest too much more in these buggy SHIVs unless I happen to have a lot of resources lying around.

    This is on PC. Great game otherwise, just hope these bugs get fixed! :-)
    Exact same problem, except on PS3

  25. #25
    Join Date
    Oct 2012
    Posts
    1
    same problem on PC.

    1. Build alloy shiv
    2. Shiv destroyed on mission
    3. Next shiv built (whether already existing or built after the 1st is destroyed) can't be added to squad and no model in barracks
    4. The next shiv after THAT is fine... but then the cycle repeated.

    Really annoying! Please fix this bug!

  26. #26
    Join Date
    Oct 2012
    Posts
    1
    Also getting this bug.

    Two unusable Alloy SHIV's

  27. #27
    Join Date
    Oct 2012
    Posts
    5
    Also encountering this...

    It's almost as if in the table of available SHIVS, when one gets destroyed, it removes the ID from the table, but the "destroyed" value is not removed from the entry... and the next built one gets inserted into the table in the first open space, but doesn't automatically set it's state to "not destroyed"... so there are conflicting data points.
    -The destroyed one is just no longer there
    -The newly built one is there, but inherits the "destroyed" flag
    -The game sees the new SHIV, so it lists it, but can't deploy it because it reads as "destroyed

    Although my theory seems to falter a bit with why a single destroyed SHIV results in the two replacements being dead weight... might have something to do with how it adds entries when building multiples... adds one and then copies that entry for each additional one in the batch?

  28. #28
    Join Date
    Oct 2012
    Posts
    1
    Yup: Invisable, un-deployable, weaponless SHIVs on the 360. A much needed but otherwise lost edge on higher difficulty play.
    Please fix this bug.

  29. #29
    Join Date
    Oct 2012
    Posts
    2
    Same problem here. Multiple Shivs unable to deploy an do not render in Viewing. Perhaps a quick patch could allow a full refund or credits and resources when choosing to dismantle. This at least would allow you to rebuild another at no cost except loss of time. Please do something soon though, it is very very frustrating to waste resources on a broken unit.

  30. #30
    Join Date
    Oct 2012
    Posts
    1

    SHIV problem

    Built one regular SHIV. Took it into battle and it was destroyed. Built another regular SHIV (had not researched any of the improved SHIV techs yet). Unable to load this one on the SkyRanger. When you view it in the barracks, it's invisible. The only choice allowed is to dismantle it.

  31. #31
    Join Date
    Oct 2012
    Posts
    2
    Same problem, and it's the headless female rookie in missions, built another one but that just makes the "X-COM says no" sound when I try to select it.

  32. #32
    Join Date
    Sep 2012
    Posts
    7
    Same here on the PC version.. cant deploy any of my new Shivs. I didnt see the headless rookie yet but it doesn't appear on the view soldiers menu. I was able to deploy newly built hover shiv but it didn't have any weapons inside. All I can do is make it fly. lol

  33. #33
    Join Date
    Oct 2012
    Posts
    5
    I just got this fault too. Invisible hover SHIV that can't be deployed.

  34. #34
    Same here!

    This is annoying, because this was my most fun game to date

  35. #35
    Join Date
    Feb 2010
    Posts
    4
    Same problem here...

  36. #36
    Join Date
    Oct 2012
    Posts
    3
    Try building a batch of two shivs after you have one destroyed. It somehow worked for me. I dismantled the glitched one and built two additional and could use them again.

  37. #37
    Join Date
    Oct 2012
    Posts
    14
    I have the same problems, two alloy Shiv's don't want to let me deploy them, built a new one, it still won't deploy. Built a hover shiv and it don't have a gun and won't fly. I have decided that I'll just scrap them all and deploy only people for now on. I'll use rookies for decoys to look for aliens and draw fire instead.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •