Results 1 to 4 of 4

Thread: Intel i7 stuttering game issues

  1. #1
    Join Date
    Apr 2012
    Posts
    6

    Intel i7 stuttering game issues

    I am having choppy game play. I have an Intel i7 with 16GBs RAM, GeForce GTX 560 Ti with 1GB, can play all other games smoothly, but in XCOM I get very laggy cut scenes, some choppy hang ups during combat movements, and occasional delayed soldier movements. I have updated all of my drivers, BIOS too, but problem STILL persists. Downloaded the D9 as suggested above, no help. Any other ideas? I had this exact issue with the demo as well. Especially when the soldiers are finished with a mission and it has the Skyranger cut scene flying into the moon, that is VERY slow, laggy, and choppy. I am also running a RoG Extreme IV system

  2. #2
    Join Date
    Sep 2012
    Posts
    17
    http://forums.2kgames.com/showthread...ght=laggy+xcom

    i think yours should be the same problem as this

    edit: didn't know you posted there as well
    Last edited by h1rono8u; 10-12-2012 at 01:22 AM.

  3. #3
    Join Date
    Apr 2012
    Posts
    6
    I wasn't getting a reply on that thread so I made my own.

  4. #4
    I have a Core i7 860, and the same video card by EVGA. 8GB of RAM and the game generally runs flawlessly on max settings in 1680x1050. I get skips sometimes when Berserkers are running around though, but I think that's some kind of bug. Windows 7 Ultimate.

    I noticed problems like you said when I forgot I had a hard drive defrag running on the same drive the game is on. So that kind of skipping can be caused by disk latency. I would check out some disk benchmarks and see if the speed seems right. CrystalDiskMark is good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •