Results 1 to 15 of 15

Thread: Addition to knowledge base: No sound when playing Bioshock with Realtek onboard sound

  1. #1
    Join Date
    Jan 2007
    Location
    San Francisco, CA
    Posts
    7,528

    Exclamation Addition to knowledge base: No sound when playing Bioshock with Realtek onboard sound

    thanks to some of our awesome 2K forum helpers, there is a new addition to the knowledgebase that should help a lot of you:

    In some cases you may encounter stuttering sound or no sound at all when playing Bioshock with a combination of Windows Vista and Realtek onboard sound. To ensure the best possible sound performance from your system when playing Bioshock, please follow the steps below:

    - Ensure you are running the latest Realtek drivers, these can be downloaded from Realtek directly via Realtek. Alternatively your motherboard manufacturer will also be able to provide up to date drivers.

    Note: If you are encountering any other issues with your sound or if you are in doubt as to what software you need then please contact your motherboard manufacturer prior to installing any driver software.

    - Enable Stereo mixing, to do this browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices. This should show an additional device called Stereo mixing, right click on this device and select Enable.


    http://support.take2games.com/cgi-bi...i=&p_topview=1

  2. #2
    Join Date
    Dec 2007
    Posts
    8
    Seems to be working for me on Vista 64bit, still get the stuttering on the loading screen but ingame it is working fine. Also cleared up the texture problem I was getting so it must have been some sort of knock on effect on the games performance.

    On Vista 64 bit it is not actually called stereo mixing, it is known as CD Audio and is under the record tab.

  3. #3
    I`ve got Vista 64 too and I do have stereo mix and cd audio on mine.I`ve just tried turning off stereo mix and turning on CD audio and that does work as well!I surpose it`s best to have both on.

  4. #4
    Join Date
    Jan 2008
    Posts
    3

    Smile Realtek fix works!

    Thanks Elizabeth that fix worked and I now have in game sound...

  5. #5
    Join Date
    Dec 2008
    Posts
    3
    Hi Elizabeth,

    How can I fix this problem in Windows XP SP2?

    I'm getting the same stuttering glitches on the audio and I've tried every possible fix your company and other users have suggested (including tweaking the default.ini, audio acceleration settings, audio latency settings, directx, running in win2000 compatibility mode etc, etc) and non of them work for me.

    I know it is not a problem with FMOD's audio platform. Crysis:Warhead uses the same engine and it's flawless on my system.

    I've tried the onboard soundcard (Realtek HD) and I also have an RME Hammerfall DSP Multiface sound card (used for my music production) which is capable of handling even the most extreme audio demands (24bit, up to 192KHz playback, 200+ audio tracks, etc, etc). My PC is fine, trust me.

    All my graphics, sound, windows software/drivers are up to date.

    So, please kindly let me know if you have a solution for Win XP users.

    Thanks,

    Mike.

  6. #6
    Join Date
    Dec 2008
    Posts
    3
    *BUMP*

    2K Elizabeth, did you see my post? or the emails i sent to you?

    Need some kind of response from the company on this please...

    Thanks.

  7. #7
    Join Date
    Sep 2007
    Posts
    18
    That's strange I posted this info in it's own topic 1 week ago (it was still on page 2 of this forum)

    This is a repost:

    Realtek onboard audio and Vista....a solution.

    --------------------------------------------------------------------------------

    Hi,

    I have seen this tip posted here before (usually very hidden and scattered), but I thought it was important enough to have its own post in full display, within easy reach.

    My problem:
    I have no sound in Bioshock in Vista (32bit) from the menu screen onwards, I fixed it originally by the tip in the sticky to change compatibility mode to XP SP2 on the shortcut. It worked, but had the unfortunate side effect of making the game randomly crash on the menu screen, until I forced -dx9 on the shortcut as well.

    So my choices were DX9 with sound OR DX10 with NO sound, and I had been struggling with this problem for days (pulling my hair out) until I read this little gem of a tip on another forum:


    Quote:
    "Then followed these instructions.

    Enable Stereo mixing, to do this browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices. This should show an additional device called Stereo mixing, right click on this device and select Enable.

    And now all is sorted and working perfectly."

    This worked a treat, now I am enjoying Bioshock @1920x1200 at max in DX10 with full sound, runs like butter.

    I don't claim that it will work for everyone, but give it a go if you haven't already. It should be the first thing you try if you have hardware/software combo in the thread heading.

    Make sure you remember to turn OFF all compatibility modes on your shortcut to get DX10, and delete all command line additions just in case.

    Hope this helps someone,

    Tony.

  8. #8
    Join Date
    Dec 2008
    Posts
    3
    Hi Tony,

    Thanks for the post, I'm sure it will help some people. Unfortunately I'm having problems on XP, not Vista.

    Anybody know of a fix with audio problems on XP? See above for more details on my prob...

    Cheers.

  9. #9
    Join Date
    Jan 2010
    Posts
    3
    Important for guys on Win7 with Realtek who can't find the enable stereo mix option.

    Well, I finally got it workin' on my new system with the stereo mix fix,
    But I was seconds from giving up because I couldn't find the stereo mixing option - the (Classic View) pointer above threw me abit.

    My System is:
    Intel Quad Core
    OS: Win 7
    nVidia 8600
    2GIG Ram.

    I'm so delighted it runs now - I bought the game about 2 years ago on Steam
    but my old system could barely handle it at min settings.
    However I stuttered thru the first part, so I KNOW this game is unplayable without the sound fully working - as you miss all the great acting, atmosphere etc.Truely - the voice acting is Top Notch.
    "You promised me 'pretty Stienman - pretty, now look at me , LOOK AT ME!!!! SCREAMMMM!!!!'
    That one sent shivers down my spine for sure!
    So, no sound - don't even bother.

    Anyway, I went thru the sound options for my Realtek Onboard a few times a few different ways, but couldn't find the Stereo Mix option - so I assumed I didn't have it.
    This was over a period of a few weeks - but tonight I thought I'd give it another try - and I thank-Full I discovered it.
    New to win7 , and it takes abit of getting used to as things are laid out a bit differently from the realtek panel in XP.

    -----------------------------------------------------------------------
    So for anybody whos stuck finding the Enable Stereo Mixing option,
    Here is a step by step for WIN7 (non-classic)

    1:
    Click the start button bottom left, then the Control Panel button to open the control panel.

    2:
    Look for the icon (usually a greyish speaker) named SOUND, and click it.
    Your presented with a small window entitled Sound, with 4 Tabs named:

    Playback Recording Sounds Communications

    across the top.

    3:
    Select the Recording Tab - and you may be shown only Microphone icon and Line In -
    with small grey print saying Not Connected.

    4:
    This is the bit where you discover Win7 has kinda tricked ya.
    In the Recording Tab, If you Right Click anywhere on the white window pane below any displayed
    icons - you will be presented with a choice of options:

    Show Disabled Devices
    Show Disconnected Divices


    Tick both of these and Presto! , the mysterious Stereo Mix icon suddenly appears - presumably as disabled.

    5:
    RightClick on the Stereo Mix icon, and from the options tick Enable.
    It should the appear nice and bright with a lovely green tickmark beside it.

    6:
    Hit OK - and thats it! Your all set.

    -------------------------------------------------------------------
    Sorry if this annoys some people, but I had all but given up on getting Bio to work on my new system.
    I even re-downloaded and re-installed it twice! -
    thanks to Win7 default secrecy on the RealTek panel - lol.

    regards
    Ausser.

    PS:
    Many Thanks for the initial pointers on the problem Liz.
    Last edited by ausraider; 01-21-2010 at 08:03 PM.

  10. #10
    Join Date
    Jan 2010
    Posts
    3
    Double post sry.
    Last edited by ausraider; 01-21-2010 at 08:02 PM.

  11. #11
    Join Date
    Jan 2010
    Posts
    3
    Dbl Post sry.

  12. #12
    Join Date
    Jun 2009
    Location
    Fleet Hall, Fort Frolic
    Posts
    314
    That's why I'm with Xbox 360.

  13. #13
    Join Date
    Feb 2010
    Posts
    1

    Exclamation Have no mixer!

    I am running vista 64bit and have tried the fix above, but there is no sound mixer in that option. I have tried looking for it in all the sound options and yet to find it.

    Any ideas would be very helpful now.

  14. #14
    Stereo Mix only shows up if you install the Realtek drivers.
    Windows own drivers dont have this option enabled.

  15. #15
    Join Date
    Sep 2010
    Posts
    1

    Thumbs up

    Quote Originally Posted by 2K Elizabeth View Post
    thanks to some of our awesome 2K forum helpers, there is a new addition to the knowledgebase that should help a lot of you:

    In some cases you may encounter stuttering sound or no sound at all when playing Bioshock with a combination of Windows Vista and Realtek onboard sound. To ensure the best possible sound performance from your system when playing Bioshock, please follow the steps below:

    - Ensure you are running the latest Realtek drivers, these can be downloaded from Realtek directly via Realtek. Alternatively your motherboard manufacturer will also be able to provide up to date drivers.

    Note: If you are encountering any other issues with your sound or if you are in doubt as to what software you need then please contact your motherboard manufacturer prior to installing any driver software.

    - Enable Stereo mixing, to do this browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices. This should show an additional device called Stereo mixing, right click on this device and select Enable.


    http://support.take2games.com/cgi-bi...i=&p_topview=1
    I had the same problem, bioshock.exe crahes, I changed my Default.ini to AudioDevice=D3DDrv.D3DAudioDevice and worked but with no sound in-game, I have a realtek too in windowz 7 and the steps above WORKED!!!!! THANKS!

    Operating System
    MS Windows 7 64-bit
    CPU
    AMD Phenom II X4 965 45 C
    Deneb 45nm Technology
    Motherboard
    ECS A790GXM-AD3 (CPU 1)
    Graphics
    SyncMaster @ 1600x1200
    512MB GeForce 9400 GT (ZOTAC International) 49 C
    ForceWare version 257.21
    Audio
    Realtek High Definition Audio


    by the way.. I don't know what windows update or steam update or what the )(/&%$# made this because it was working just fine a week before....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •