Page 1 of 2 12 LastLast
Results 1 to 40 of 47

Thread: nVidia and Bioshock Stuttering

  1. #1
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    5,532

    nVidia and Bioshock Stuttering

    Edit: People are reporting success with the instructions given in the next reply. The stuttering only seems to apply to Windows XP. If you are using Vista and have had the stuttering *and/or* have had these instructions fix it then we'd be most interested if you could drop a reply in this thread. Thank you, and all thanks to Karvig.

    ==

    nVidia's newer drivers seem to have introduced stuttering with Bioshock. As a work-around you can try the 178.24 or older drivers. This is not a good solution but it is all that can be done for right now. Direct links to the drivers are:

    Windows XP 32-bit
    Windows XP 64-bit

    Windows Vista 32-bit
    Windows Vista 64-bit

    As of this writing the current driver version is 190.38. These drivers although better than previous ones still stutter. Please post with the results of newer drivers and Bioshock as they become available.

    Here is a: relevance link into nVidia's forums.
    Last edited by headkase; 07-27-2009 at 08:30 PM. Reason: Karvig's solution seems to be good.

  2. #2
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    5,532
    User Karvig, in: This Thread offers a possible solution while using the latest drivers. I can't link to the post directly because of some weirdness with nVidia's forums and Chrome so I'm reproducing the text here. Can an nVidia owner confirm these instructions?

    Good evening
    Have been playing Bioshock for the last 2 hours with the latest Geforce Nvidia Drivers (v190,38)
    As many of you, I too enjoy to go back to a nice quick holiday tour on rapture from time to time

    ... snippage ...

    under the
    Manage 3D settings menu
    Manage 3D settings (Program settings)
    Access the bioshock application specific settings and change the value
    "Maximum pre-rendered frames" - Use Global Setting (8)
    to
    "Maximum pre-rendered frames" - 0


    And from now on I just hope that you can enjoy Bioshock just as I have been enjoying for this last 2 hours
    (under drivers v190,38 that is)

    I sincerely hope that this helps at least one more person because the current "fix",
    of using the v178,24 is something that I would have never think about and without that
    I would have not been able the keep enjoying Bioshock
    And for that I am really thankful to the whole bunch of you

    ... snippage ...

    Well
    I guess this covers it all
    Cheers and have a nice rapture holiday tour


    If these instructions are confirmed to work then a big thank-you goes out to Karvig! So, the setting to test is to set the maximum prerendered frames to 0. I believe that Karvig is correct in pointing out this setting specifically: see the original post for the rest of the settings he used if this one setting does not improve Bioshock.
    Last edited by headkase; 07-25-2009 at 12:49 PM. Reason: condensed quoted post - see link to original for full text

  3. #3
    Thanks to Karvig!

    Turning the maximum pre-rendered frames to 0 worked for me. Game play shows none of the stuttering in XP anymore. Though, there is a sizable pause each time I take pic with the camera.

    So nice to be able to play Bioshock in XP again.

  4. #4
    Join Date
    Jul 2009
    Posts
    1
    thanks ! "Maximum pre-rendered frames" - 0 worked for me.

  5. #5

    Thumbs up

    Setting Max pre-rendured frames to zero '0' absolutely worked for me. Running geforce 190.38 on my 8800GTS and it's smooth as silk.

    This fix does work.

  6. #6
    Join Date
    Oct 2008
    Posts
    5
    What does this setting do? Are there any negative effects to using a setting of 0 as opposed to the default 3 I believe?

  7. #7
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    5,532
    rahzel: This setting corrects a driver error for nVidia users. It makes the game playable. You also only set it for Bioshock (the application specific profiles) so it will not change it for your other games.

  8. #8
    Join Date
    Mar 2009
    Posts
    9
    This is excellent news, Headkase! I tried it myself a few minutes ago, and it does indeed work!

    I can't help but wonder, though, if the solution was that simple, then why didn't nVidia discover this on their own and why couldn't they have just automatically implemented it in a profile for the game rather than have us go into the control settings and figure it out for ourselves? The Unreal 3 engine isn't that complicated, I don't think. (Not that I'm averse to doing some manual tweaking of the game if I have to. I'm just saying.)

    Anyway, I'm glad to be able to play the game at a smooth framerate without having to switch back to an older driver. Muchos gracias!

  9. #9
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    5,532
    All thanks to Karvig, he's the one who figured it out! So, again, thank you Karvig!

  10. #10
    Join Date
    Aug 2009
    Posts
    2
    Hey, i just registered so i could ask if this fix is supposed to work with the steam downloaded version of Bioshock? I just got and the lag is intense with doors opening and all conflict. I tried to changed the max pre-rendered frames to zero but bioshock isn't on the list when i try to add it, the fix doesn't work.


    (also i don't think it is an internet problem because i tried both online and offline and also i run TF2 and L4D fine)

    I have a 2.4 quad core
    nvidia 9600 with 903 patch
    3.22 GB of ram
    XP OS

    sorry if i broke any rules on these forums i don't usually post on them.

  11. #11
    Join Date
    Aug 2009
    Posts
    8
    Good evening

    Let me pick as a start point just a warm "Hi there" to everyone

    Originally I had no intention in performing the registration in the
    current forum since this thread (the one that I have been
    recently looking at) has been superbly supervised by user
    Headkase (who has also been doing a great job updating it
    with all revelant info out there on the net)

    But the new issue, quoted below, stands out by itself as a completly
    different situation (not addressed before as far as my knowledge goes)

    Quote Originally Posted by Cassidym View Post
    Hey, i just registered so i could ask if this fix is supposed to work with the steam downloaded version of Bioshock? I just got and the lag is intense with doors opening and all conflict. I tried to changed the max pre-rendered frames to zero but bioshock isn't on the list when i try to add it, the fix doesn't work.


    (also i don't think it is an internet problem because i tried both online and offline and also i run TF2 and L4D fine)

    (...)

    sorry if i broke any rules on these forums i don't usually post on them.
    The final remark may actually be true

    I don't believe that 2kgames are directly responsible for the steam
    release

    Even so, and keeping up with the original premise that made me
    start the forums registration, improving support provided on all Bioshock
    fanbase community I will try to address your topic as best as I can

    I agree with your opinion that the issue is not internet related

    Also it is almost predictable that Bioshock does not feature itself
    on your Nvidia Control Panel application list since it is a Steam version

    I don't use Steam nor do I know of anyone that uses it and owns Bioshock
    through that same system
    With this being said, I must leave as a top note the fact that I am not
    able to test any of the solutions that I will suggest below so they just
    may not work

    Even though I am not a Steam user I believe that Steam wraps any
    sold application inside its main execution system thread (the Steam
    engine that is)

    So this leaves us with three options I believe

    -------------------
    First Option
    -------------------

    If you have some computer programming knowledge
    create a wrapper application for the Steam main
    executable

    When launching the Steam application from within
    the wrapper you must make sure that the Steam
    executable never leaves the context of execution
    of your wrapper application

    Also your wrapper application must call the
    Steam main executable passing the it through
    command line option, the correct value to
    directly launch Bioshock
    (since I don't have Steam I don't know if this is
    possible but I would assume that one can do something
    as
    Steam.exe -run Bioshock
    or similar)

    Access Nvidia Control Panel

    Now

    3D Settings
    | |
    | +----Manage 3D Settings
    | |
    | +----Global Settings

    Click the ADD button

    Now browse through your computer folders until you find your wrapper
    application executable file

    Leave all the settings for that application under default
    except for the

    "Maximum pre-rendered frames"
    Set its value to 0 (ZERO)

    Now Go to

    3D Settings
    | |
    | +----Adjust Image Settings With Preview

    Choose the option

    "Use the advanced 3D image settings"

    -------------------
    Second Option
    -------------------

    Access Nvidia Control Panel

    Now

    3D Settings
    | |
    | +----Manage 3D Settings
    | |
    | +----Program Settings

    Click the ADD button

    Now browse through your computer folders until you find the file
    "Steam.exe" (or whichever is the Steam launcher main executable)

    Leave all the settings for that application under default
    except for the

    "Maximum pre-rendered frames"
    Set its value to 0 (ZERO)

    Now Go to

    3D Settings
    | |
    | +----Adjust Image Settings With Preview

    Choose the option

    "Let the 3D application decide"

    -------------------
    Third Option
    -------------------

    Access Nvidia Control Panel

    Now

    3D Settings
    | |
    | +----Manage 3D Settings
    | |
    | +----Global Settings

    Leave all the settings as they are
    except for the

    "Maximum pre-rendered frames"
    Set its value to 0 (ZERO)

    Now Go to

    3D Settings
    | |
    | +----Adjust Image Settings With Preview

    Choose the option

    "Use the advanced 3D image settings"



    Now, lets review all Cons and Pros for the above
    solutions

    -------------------
    First Option has no Cons
    -------------------
    but it requires some extra computer knowledge from yourself
    (I don't go as far as saying Academic Computer Science but
    a little up there on the road)
    If you don't feel that you have the needed skills for it,
    then simply skip that option

    -------------------
    Second Option
    -------------------

    Before applying it, make sure to write somewhere which
    were the original settings for the options that you have
    changed

    Above all, if this method does work, then each time
    a Steam application is launched but a different game
    is played, the

    "Maximum pre-rendered frames"
    Set its value to 0 (ZERO)

    also sets that specific game
    because the Steam application wraps the execution context
    of any game launched through it

    Being so, each time a different game is launched, reverting
    to the original graphic settings may be needed to keep
    on enjoying the game as good as it was before (leaving
    "Maximum pre-rendered frames"
    Set its value to 0
    will cause no harm to the majority of your gaming applications
    but some may suffer from it)
    If this does happen then the original graphic settings
    must be restored
    (I am talking about fluid gameplay nothing worse )

    -------------------
    Third Option
    -------------------

    The reasons discussed for the second option apply to this
    case
    But now it is not only a Steam application that gets bounded
    to your new settings but any application on your system (yes,
    even a notepad.exe even though I am sure you will find
    no difference whatsoever)



    Possibly you can created different profile settings on the Nvidia
    Control Panel and whenever playing Bioshock you could just switch
    to the desired profile
    When exiting Bioshock you would revert your active profile to the
    usual one
    But if this is possible, I just don't know how to do it (although I
    have never searched or tried to but I would assume that if it is
    possible, then it cannot be all that hard)


    I guess (and pretty much hope) this covers it all

    But as in a one hand washes the other policy I would
    ask to provide us with a reply letting us know if any (or all) of the
    above options have worked so that I can post it in the other forums
    where I have tried to provided some assistance over this issue,
    because this is a topic that I have not faced until now but
    on the other hand sounds as important as the rest that
    also face the stuttering issue

  12. #12
    Join Date
    Aug 2009
    Posts
    2
    Karvig, you are an absolute legend. You guessed right in thinking i don't have the computer knowledge to create a executable wrapper and i found that using the steam.exe in program settings didnt work, but using global settings Maximum pre-rendered on zero frames did the trick.
    Now all i have to do is change it before i begin playing to enjoy bioshock.
    Cheers for all the no-how and proper explanations, you have put my trust back into the internet.

  13. #13
    Join Date
    Aug 2009
    Posts
    8
    @Cassidym

    Hooray

    Great news ! Thanks for the reply
    Going to post it in the others forums as well

    Lets spread the word

    Oh, and by the way

    Welcome to rapture

    If you find me around,
    Don't kill me,
    Splice me up

    Cheers

    Going off-topic now
    The following is some sort of manual signature

    Is there no way to enable an auto signature for a user profile ?
    (not that it is important. just checking )


    --------------------
    Anything posted, I just hope it helps
    Cheers

  14. #14
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    5,532
    Thank you Karvig, you resolved an issue that was plaguing nVidia and Bioshock customers. You deserve a big round of applause and, yes, your posts have now helped quite a few people. *Applause* You are to be commended.

  15. #15
    Join Date
    Aug 2009
    Posts
    1

    Choppy Graphics

    Your tip works a treat thank you all , its has been driving me insane for so long.ty.Karvig take a bow u did more than nvidea did so ty very much.
    Last edited by danny52002; 08-21-2009 at 11:25 AM.

  16. #16
    Join Date
    Jun 2009
    Posts
    10
    This doesn't work for me.

    It fixes the "streaming" issue - there's no stuttering when I move from area to area. But, there is significant stuttering when a Big Daddy walks across the screen, or an enemy apppears.

    This is not a hardware problem, as everything works fine under Windows 7. Smooth as glass.
    Last edited by Dascomrade; 08-25-2009 at 05:55 PM.

  17. #17
    Join Date
    Aug 2009
    Posts
    8
    Good afternoon

    @Dascomrade

    Well. Your posted issue stands out a little bit too vague

    You say everythings runs fine using Windos 7

    So where does it stutter ? Vista ? XP ?

    Also. In order to address your situation in the best way as
    possible things that also help are

    Steam or Retail version (after user Cassidym post, I believe this
    becomes also an important subject)

    Hardware Specs (especially CPU, GPU, soundcard, RAM total
    and respective drivers' versions are also very helpful)

    I understand that posting all the info may be tedious if not for
    anything else, at least for the fact that you can never be sure
    that anyone will address your issue but if someone can, well
    that info may just be a great kick start

    But before posting I will suggest the following

    Read carefully the current thread (one we're posting on)
    Different solutions for different scenarios have been presented
    along the way. Try them (if some does not address your current
    scenario for sure just skip it )
    Also do the same for the following threads

    http://forums.nvidia.com/index.php?showtopic=95845&st=0

    http://forums.2kgames.com/forums/showthread.php?t=15266

    And now a more generic thread but that may also help

    http://www.hardforum.com/showthread.php?t=983781

    Even if all this info does not help in your current Bioshock prob,
    well, I'm sure they may be helpful in some future situation you
    encounter so it will never be a waste of time

    After all this, if you have the chance, just post your remarks
    either saying that the forum's info was helpful or not and if not
    just post the extra system info I refered above so that we may
    help further

    Bioshock fanbase community is from what I have seen so far,
    a solid one and being so I am sure that sooner or later a solution
    will come up

    For now, best of luck

    Cheers mate

    Taking the chance to go again off-topic but I was not answered
    in the first place

    Do 2kgames forums have the option for a user to create a
    personal auto signature (each time the user posts the signature
    text just concatenates itself to the bottom of the post) or not ?

    --------------------
    Anything posted, I just hope it helps
    Cheers

  18. #18
    Join Date
    Jun 2009
    Posts
    10
    Sorry, I posted my system specs over in the other thread and didn't think. Under normal conditions, my PC is as follows:

    XP MCE 2005 with SP3.
    Gigabyte EP43-UD3L motherboard.
    Intel C2D Q9550 at stock.
    4GB G.Skill DDR2 1066 at stock.
    NVIDIA GTS 250 1GB at stock.

    As stated, BioShock works flawlessly under Windows 7 RC. I've tried every fix listed for the XP stuttering, but the only one that "surely" works - going back to 178.24 - is an unavaliable option to me. My graphics card is not supported by that driver.

  19. #19
    Join Date
    Aug 2009
    Posts
    8
    Quote Originally Posted by Dascomrade View Post
    As stated, BioShock works flawlessly under Windows 7 RC. I've tried every fix listed for the XP stuttering, but the only one that "surely" works - going back to 178.24 - is an unavaliable option to me. My graphics card is not supported by that driver.
    Hi there

    Regarding your posted system specs and since you state that you have
    tried all the listed possible fixes there is not much more I can add for now

    But before dropping the subject (for now that is), I believe that
    you should at least try to narrow your issue down to being a graphical
    issue or not

    From what I understood the only fix you haven't tried is the

    reverting back to v178,24 drivers

    the reason you stated is

    ""
    My graphics card is not supported by that driver
    ""

    Well sir, I cannot assure anything on that matter since I do not
    own that particular graphic card but I believe your card is supported
    by that driver version

    If you go to the Nvidia web page, indeed that driver does not
    show on the listing drivers for your card but if you jump to
    the driver section itself

    US version

    http://www.nvidia.com/object/winxp_178.24_whql.html

    Internation release version

    http://www.nvidia.co.uk/object/winxp...4_whql_uk.html

    And look into the "supported products" section your card shows up
    as being supported by that specific driver version
    (at least on the US version supported products section)

    Again I must remind that I cannot test this myself and you should
    probably search a little online just to check it out before trying
    to use that driver version but if you find no complaints about using
    that drivers set on your card I believe that should be done

    If the stuttering goes away when using those drivers then it is
    indeed a graphical issue if the stuttering does not go away then
    maybe you must try to address your situation with a different
    approach

    Probably something to do with the quad core config ?
    I admit that if it is not a graphical issue then I don't have a clue
    but at least you could narrow your search a little bit

    Well best of luck

    On a second thought

    Before trying to previous drivers set keep the settings changes
    you made that solved the '"streaming" issue'

    Now edit the following file

    C:\Documents and Settings\YOUR_USER_NAME\Application Data\Bioshock\Bioshock.ini

    (remember to backup the original file prior to editting,
    if something goes wrong you can always revert to the original
    one without any hassle)

    Now on the HAVOK section set the option

    HavokNumThreads=

    to

    HavokNumThreads=4

    If this does not work, revert to the original INI file and try
    the driver suggestion above

    If possible keep us posted just to know how it went
    (it just may help someone in a similar situation)

    Cheers

  20. #20
    Join Date
    Aug 2009
    Posts
    2

    Trouble running..

    Hey all, I'm not hundred percent sure this is the place to put this, but I really need some help. My bioshock is lagging (jerking) on high graphics and slightly even on medium graph. Im not sure if the word for that is stuttering like you all said.. anyway I've got a 2.5 dual, 3gig ram and 98GT so cant imagine its the hardware. Not sure what windows I'm running, but its an oldish version of XP. Im not planning on going to vista any time soon. Please help!

  21. #21
    Join Date
    Aug 2009
    Posts
    8
    @Ryan246

    Good afternoon

    First of all I am not sure about your graphic card but when you say
    98 GT I believe you are actually using a Nvidia 9800GT card

    Anyway there is not one-fits-all-scenarios solution

    Being so, the only way for you to try to address the problem is
    reading the entire thread (from the beginning) and try one by one
    all the solutions that have been presented

    Eventually one will fit your needs

    If after applying each solution you don't find one that clears the problem
    entirely then post which one (or ones if more then one adds up to
    the overall gameplay performance) have provided you the better gameplay
    so far so that we may try different approaches

    But before trying each solution there is not much that can be added
    simply because, as stated above, there is no
    one-fits-all-scenarios solution

    Cheers and best of luck

    EDIT:
    There is one possible specific solution for your issue although I cannot be
    certain about this
    Bioshock declares Windows XP SP2 as a minimum compatible OS
    You say that your Windows XP is an oldish version
    By itself that does not shines light on the subject
    But you can try to figure out the correct release of your OS through one
    of two procedures

    First:
    Access the Windows Control Panel
    Now access the "System"
    On the default "System" tab your Windows version should be shown
    with the reference to its current update status

    Second:
    Start Menu
    From there go to
    All Programs - Accessories - System Tools - System Information
    Among all the info shown up some concerning the current OS version should
    also be presented

    But as stated before I cannot say that using a Windows XP pre SP2 installation presents
    itself as a real problem because I have never played nor do I know of anyone that has
    tried to play Bioshock with a Windows XP prior to SP2 release
    Last edited by Karvig; 09-01-2009 at 01:41 AM.

  22. #22
    Join Date
    Aug 2009
    Posts
    2

    Stuttering

    Thanks bud, wasn't expecting quite all that effort and patience with a less than competant PC operator. Yeah I'll try the suggestions in the rest of the forumns, but can't diddle around with drivers windows till the weekend. I'll have a scratch then, many thanks.

    BTW yeah it's a 9800 GT nivida. Got it recently so not too chuffed with having to run bioshock on med hehe. Cheers

  23. #23
    Join Date
    Jun 2009
    Posts
    10
    Karvig,

    I tried setting the Havok threads to 4 to no avail. I still get severe stuttering under XP.

    I also tried installing 178.24, but it reported that my hardware wasn't supported, so the driver would not install.

    What can I do? It can't possibly be a hardware problem. The game does run fine under Windows 7 x64, and I played it to completion for the first time under that OS without a single problem.

  24. #24
    Join Date
    Sep 2009
    Posts
    2
    Don't know if this was mentioned elsewhere, so if has been I apologize....

    But for the Steam Version of Bioshock, to Change the Max Pre-Rendered
    Frames to Zero, simply uncheck the "Show only programs found on this
    Computer" box, and you can then select Bioshock. No need to change the
    global settings.

    I'm assuming it doesn't show up because Steam keeps it's games in a
    kind of 'disc image' file. When you load a Steam game, the image is mounted
    and Bioshock.exe is executed... it sets your Max Pre-Rendered frames to 0.
    No more stuttering...


    Well, it worked for me, anyways.

    PS - I realize that it's not ACTUALLY a disc image, but that is the easiest
    way to think of it, as the files are actually stored in the
    ../steam/steamapps/common directory.
    Last edited by woodman; 10-01-2009 at 06:02 PM.

  25. #25
    Join Date
    Aug 2009
    Posts
    8
    Good afternoon everybody

    @woodman

    Sir, the info you just gave has not been refered before and
    it is quite valuable in fact

    If you are right (and since it worked on your system, I can only
    assume you are) this brings a huge "upgrade" on the previous
    way to address the Bioshock issue running on Steam

    If

    Cassidym

    is reading this, could you test the above procedure on your system ?

    Working on your system clears out all eventual doubts about the
    effectiveness of the procedure

    And also

    Quote Originally Posted by woodman View Post

    (...)

    I'm assuming it doesn't show up because Steam keeps it's games in a
    kind of 'disc image' file. When you load a Steam game, the image is mounted
    and Bioshock.exe is executed...

    (...)
    If you are right, and I do believe you are, this shines quite an
    interesting info concerning the way the Steam engine wraps any
    application running through it

    As a matter of fact, we could check this just "now"

    Woodman, if you are running a Win XP either Professional or Server
    edition, start your Bioshock through Steam, then drop to desktop
    (don't close the application, keep it running but return to desktop
    Alt-Tab it or something)

    Then Start menu, "Run..."

    Type

    cmd

    now under the command console type

    tasklist

    Check out the presented list and check for the

    Bioshock.exe

    If it shows up you are 100 right on the spot

    I guess that this can also be checked out through "Task manager"
    if the above doesn't word

    Anyway, great update on the Steam issue

    Thanks

    Now

    @Dascomrade

    I am not sure how we can try to solve your prob

    But lets try something

    Before going on, I assure that I am not trying to send you
    on a wild goose chase but since I don't know how to ressolve
    this exactly, this is the best I can do

    First things first

    Lets make sure you are running Bioshock v1.1

    If you are skip the next steps

    If you are not, then go to

    Bioshock update support

    Download the correct version for your Bioshock application

    You will almost sure go with the first one

    The second one only addresses a small fraction of the Bioshock's
    retail versions that come with a censorship cap

    Since you have played Bioshock before you will know if yours is
    censored or not

    Then apply the last Nvidia Graphic Cards driver version v190,62

    Now apply the full settings wrote on the following forum
    (it is a previous entry I did but since it is quite large, I will not
    copy it all here)

    Remember to write down previous settings somewhere so that
    you can revert to the previous settings

    Also, don't skip any of the refered settings changes (it reduces
    any transversal conflicts)

    Bioshock nvidia Control Panel settings

    Two extra notes

    Skip the driver version refered in the above post (previous to the
    current one provided by Nvidia)

    After applying all info in the post repeat the following step

    Adjust Image settings with preview - ___"Let the 3D application decide"

    Because everytime a user changes settings, Nvidia control panel
    changes the above setting to

    "Use the advanced 3D image settings"

    If it does not work by itself, before reverting to your original
    Nvidia settings try one last thing

    Start Bioshock, now access the "Task Manager" with Bioshock running

    You must press CTRL-Alt-Del

    and the "Task Manager" will show up (you must go back to Desktop
    in order for this to work. but you must do it without closing the
    running Bioshock application. Probably Alt-Tab will help here)

    Under the "Task Manager"

    Choose the "Applications" tab

    Right click Bioshock and choose

    "Go To Process"

    Right click the selected process and choose

    "Set affinity..."

    Make sure only two cores are selected (there is no
    preference, it is supposed to have four when you first check)

    And that is what I can make up now

    I am sorry for not being able to provided a "certified" solution
    but each hardware combo (along with the used OS) can be
    a specific case. Being so we can only keep on trying until
    something works out or until we run tired of all the trouble
    (sure hope the first one succeeds)

    Guess that's all for now

    Best regards

    Cheers

    --------------------
    Anything posted, I just hope it helps
    Cheers

  26. #26
    Join Date
    Sep 2009
    Posts
    2
    Bioshock.exe is listed by taskmanager for the Steam version.

    http://img201.imageshack.us/img201/9...cksteamver.jpg

  27. #27
    Join Date
    Aug 2007
    Posts
    280
    Okay, so... if I update to the 190.62 set and do the "Maximum pre-rendered frames" - 0 thing, I shoudl be able to run BioShock without issue. No stuttering.

    Okay, I've been running the 182.50 set for a long time now. As the last set I updated to gave me issues in a few other titles.


    EDIT: Okay, just upped to the 190.62 and tried BioShock... runs silky smooth. Awesome, thanks man.
    Last edited by Damien_Azreal; 09-09-2009 at 02:05 PM.

  28. #28
    Join Date
    Aug 2009
    Posts
    8
    Hi everybody

    Sorry for such a delay from my last post

    Quote Originally Posted by woodman View Post
    Bioshock.exe is listed by taskmanager for the Steam version.

    http://img201.imageshack.us/img201/9...cksteamver.jpg
    These are some great news

    Although no one else has confirmed success with this procedure, I believe
    this screenshot is as good

    Being so, I will post this info in the other forums I now of addressing this
    issue

    Once again, thank you for all that feedback. I am sure it will assist
    o whole bunch of splicers

    @Damien_Azreal

    Great news. Glad to hear it

    Guess we're neighbours in more forums than I noticed the first time

    For now there is nothing more until users previously posting troubles
    give us some more up-to-date feedback so that we can call it ok
    or try some new approaches

    --------------------
    Anything posted, I just hope it helps
    Cheers

  29. #29
    Join Date
    Sep 2009
    Posts
    1

    Woodman is right

    I have done this late last night and it worked. I did not post sooner because i was not signed up on these forums until this morning. But yes it does work...

  30. #30
    Join Date
    Oct 2009
    Posts
    6
    Setting pre-rendered frames to 0 stopped my stuttering, but it also chopped my framerate in half... literally, it went from a smooth 60 (when not stuttering) to average around 30. I'm running an 8800GT with the 190.38 drivers (downgraded from 190.68 to see if that fixed the low framerate) and have RivaTuner's D3DOverrider running in the background. I also tried it without D3DOverrider, but had the same problem. Any suggestions?

  31. #31
    Join Date
    Oct 2009
    Posts
    13
    Okay I'm really frustrated. I've read through the thread and figured out that the later drivers are causing my stuttering. I recently upgraded from an XFX GTX 260 to an EVGA GTX 275. Playing BioShock with the XFX card, using the version 177.42 drivers that came with the included CD, the game ran flawlessly. I haven't played BioShock for about six months so yesterday I decided I wanted to run through it again. Now with the EVGA 275 and the 190.62 drivers the game is a nightmare to play. I'm heartbroken. I really don't want to swap video cards to play one game but I'm leaning towards doing that at the moment.

    Here is my question. Is there anyway to force install the 178.24 drivers suggested in the beginning of this thread? My problem lies in that when I remove the 190.62 and attempt to install the others I receive an Nvidia Setup Error claiming that the driver is not compatible with the 275. It's as though Nvidia has written in to the software to not allow the 178.24 to work with later video cards so people can't downgrade. 182.50 and above will install fine but all present the stuttering issue. Even adjusting the Maximum prerendered frames setting to 0 does not take away my stuttering.

    So, is it possible to force install the older drivers through another method or must I really swap video cards?

  32. #32
    Join Date
    Aug 2009
    Posts
    8
    Good morning

    Long time since my last post

    First I would like to apologize the following user

    Jarius86

    This user never received a reply to his post

    On the other hand I don't have any new suggestions to try
    out

    So I would not be that much of a help on that matter

    However I suggest to both
    Jarius86
    and
    greens

    to read really carefully the full threads (all post) in the following links
    (the first one is this current thread)

    2kGames Bioshock Stuttering Thread

    Nvidia Bioshock Stuttering Thread

    Don't skip settings steps, as trivial as they may seem, and try each
    presented option, one by one. In the end if more than one option
    fixes the problem, keep the easiest and less aggressive one

    Sometimes the smallest detail is the answer

    On a second subject

    Quote Originally Posted by greens View Post
    (...)

    So, is it possible to force install the older drivers through another method or must I really swap video cards?

    (...)
    I hope I still answer this on time

    To install old display set of drivers, concerning Nvidia, I believe
    you have two good options

    Option #1

    Run the newest drivers package setup

    I believe you will be prompted with an option the remove the
    current set of drivers
    Reboot the machine
    Install the old set of drivers

    Option #2

    Control Panel
    Add or Remove Programs

    Select "Nvidia PhysX"
    Remove

    Select "Nvidia Drivers"
    Now, on the new dialog box, select
    "Remove only the following" + "Nvidia Display Driver"
    Remove

    Reboot the machine
    Install the old set of drivers

    Bye for now

    --------------------
    Anything posted, I just hope it helps
    Cheers
    Last edited by Karvig; 11-15-2009 at 01:42 AM. Reason: Posted links correction

  33. #33
    Join Date
    Dec 2009
    Posts
    2
    I am experiencing the stutters as well, and it is making the game unplayable (or at least not playable without wasting massive amounts of Ammo). I used the 'prerendered frames to 0' correction, and that fixed the onset of stuttering every time I changed rooms, however I still start stuttering like crazy whenever an enemy gets near me (if they are far away, this doesn't happen). So I've got a splicer on top of me and I have to just hold down the fire button and point in the general direction, because I only get a couple new frames a second. Generally when I kill them and the game comes back, I keep firing for a second (actually, more often the game comes back in the middle of the reload/injection animation, as I've emptied a clip during the stutter). Although I have died once because the splicer was behind me and I couldn't find them because they fell inside the gap created by my turning speed.

    I had no trouble playing the game on XP with this same system before I reformatted.

    My system is an Athalon X2 Dual 4600 2.41GHz with 2G memory running W764 and a GeForce 7600 GT with 195.62.

  34. #34
    Join Date
    Jan 2010
    Posts
    8

    Bioshock amd DX 1o with Nvidia problem

    Hi, I'm not sure if my problem with drivers or system. I am a user of Windows 7 32bit, I have all current drivers, direct x and bios, my graphics card is a GF 8800 GT. I have a problem running the game without the patch and with patch 1.1. After starting the game shows a black screen, after switching to the desktop or run the task manager shows a message that has encountered an error and needs to close-even though the process of "Bioshock.exe" is still active and I can not close it, it helps only a logout and re - logging into the system. On the part of the game there are no error messages, just reset all settings to default-I know because when added to shortcut the "-DX9" game starts and runs without a problem at the highest settings at 1600x1200. My graphics card is 100% efficient, I tested it 3DMark Vantage program update to the latest version. Card in it repeatedly passed all tests without any errors or artifacts. I do not know what else I could do, already tested all the possible drivers for this graphics card, together with earlier versions, beta and intended to Windows Vista.Other components of my computer is: Intel C2D E7600, 2x2GB Patriot Dual LLK CL4 DDR 2 800, motherboard Gigabyte EP35-DS3 with the current BIOS version F4a, 2x Seagate ST3250410AS 250GB HDD

    By the way-soon premiere Bioshock 2, I hope that the game has been tested in Windows 7 and will not be problems with its support DX10 in the system?

  35. #35
    Join Date
    Jan 2010
    Posts
    2
    I am not normally this "Ignorant" but where is this?
    Manage 3D settings menu
    Manage 3D settings (Program settings)
    Access the bioshock application specific settings and change the value
    "Maximum pre-rendered frames" - Use Global Setting (8)
    to
    "Maximum pre-rendered frames" - 0

  36. #36
    Join Date
    Aug 2007
    Location
    Tejas (but I've lived all over)
    Posts
    6,668
    Quote Originally Posted by wolf359 View Post
    I am not normally this "Ignorant" but where is this?
    Manage 3D settings menu
    Manage 3D settings (Program settings)
    Access the bioshock application specific settings and change the value
    "Maximum pre-rendered frames" - Use Global Setting (8)
    to
    "Maximum pre-rendered frames" - 0
    I just upgraded from a 7600Gt to a 9800GT and found the above useful.

    It is located in your Nvidia Control Panel. You should be able to find it via the Start menu, but I access mine in WinXP by right-clicking the desktop. Navigation from there is pretty straightforward. The left pane has the "Manage 3D Settings" and the the right pane will show the games you have installed and offer the various customization options listed.

    Hope that helps.

  37. #37
    Join Date
    Jan 2010
    Posts
    2
    Quote Originally Posted by japester View Post
    I just upgraded from a 7600Gt to a 9800GT and found the above useful.

    It is located in your Nvidia Control Panel. You should be able to find it via the Start menu, but I access mine in WinXP by right-clicking the desktop. Navigation from there is pretty straightforward. The left pane has the "Manage 3D Settings" and the the right pane will show the games you have installed and offer the various customization options listed.

    Hope that helps.
    Thanks, found it. I have the 9600GT. Tried it but didn't. Will keep looking.
    wolf

  38. #38
    Join Date
    Jan 2010
    Posts
    2
    Hi I have a problem with the game and I tried the to edit Bioshock.ini, Havok something and Nvdia Control Panel prerendered frames to 0 but nothing works.

    The game runs smooth with all max but for example Im now in Neptune's Bounty and the game suffers "ministops" (for less half second the game freezes and I walk a few steps), I tried with ALL Minimun and when I dont move but these "ministops" still there.

    I have a 2.5 quad core, 9600gt, 2 GB of ram and Windows XP.

    First I played with the original CD drivers but the game suffers slowdowns with that so I downloaded the lastest Nvdida drivers (196.21)

    Also, I played Crysis and COD4 demos and I havent any problems with these games.
    Last edited by Phoenix2010; 01-26-2010 at 12:21 AM.

  39. #39
    Join Date
    Jan 2010
    Posts
    1

    Stuttering issue with black boxes

    I have been through this and the aforementioned threads to try and fix my problem, but nothing has worked. The game works fine for about 3-5 minutes, then I get black boxes starting to pop up in the screen. This gets more and more frequent until the game stutters and freezes. It will sometimes unfreeze after a minute or two but continues this cycle until the game crashes.

    I have rolled back my drivers and now am running the newest Nvidia ones.

    GeForce 7800GT
    2 G RAM
    AMD 64X2 3800+
    XP

    I have also tried setting the prerendered frames to zero, turning off vertical sync, and making sure nothing is using a multicore render. Any suggestions? Thank you

  40. #40
    Join Date
    Feb 2010
    Posts
    782
    None of this solved my issue with Nvidia & Bioshock2

    If SLI is enabled the game will stutter and artifact if too much fire is on the screen or bodies. Suddenly I use one card and it works fine. Why do I want to use both cards? To turn the pretty graphics up.

    Vista x64
    Nvidia GTX295

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •