Page 1 of 15 12311 ... LastLast
Results 1 to 40 of 588

Thread: Mouse Acceleration ruining Bioshock for you? Post HERE.

  1. #1
    Join Date
    Aug 2007
    Posts
    305

    Mouse Acceleration ruining Bioshock for you? Post HERE.

    We really need a consolidated thread for this so I attempting to start one. The forced and completely insane mouse acceleration is ruining this game for me and for many others. I am down to sensitivity setting 1 (and i only use a 400dpi mouse!), putting up with the messed up cursor, aiming is still to fast and all over the place. This is in the retail copy btw, I know I said I would not buy the game until this was fixed but I gave in after playing a couple of levels on a friend's xbox, it is really is that good, reminds me of Tie Fighter when i was a kid and the feeling of awe I had while playing that game. However, I have 2 weeks to return it and I will do so if we don't hear official word from Irrational about mouse control.

    I have tried the 3 possible mouse settings in bioshock.ini and nothing works, the mouse feels like its using a 360 analog acceleration curve that was just hacked into the mouse code as an afterthought. I urge everyone to listen to the podcast about the PC version on Cult of Rapture, in which 2k australia devs. say how they know how to make a pc shooter and how it has "tight controls" and how it lives up to the standards set by other popular PC shooters. All other pc shooters have proper mouse contol that that allows you to aim accurately once you rid windows of all acceleration, set up your mouse properly, and settle on a good sensitivity (mine is 30cm/360).

    for reference my mouse is MX510, standard windows driver, "pointer precision " OFF, CLP mouse fix (kills all acceleration by editing registry), 1:1 windows speed (6th notch, if you dont believe or don't know about this go here http://www.overclock.net/computer-pe...on-guide.html).

    If you haven't gone through this process of getting rid of all acceleration, then you have been playing with it all along and probably don't even notice the problem, so please dont troll here with how "your mouse works fine". This is serious for those of us who rely on precise, unaccelerated or interpolated mouse control.

    If you have gone though this process and play with true 1:1 mouse movement, you play by muscle memory, and can react instinctively. If I hear someone behind me i know that if move my mouse 15cm to either side i will do a perfect 180 turn every time. When you play this way for a while it becomes second nature and it is impossible to go back.

    The broken mouse control makes it impossible to play Bioshock enjoyably. It goes against everything we were promised by the devs in the podcast about the PC version.

    The only official response that we have received so far is this:
    Quote Originally Posted by Bioshock_FTW! View Post
    I actually mentioned this to the project lead of 2k Australia when i met him at the launch...
    he shrugged it off. Not exactly in their power to do anything about right now. Hopefully we'll be seeing a patch within a week or two to handle these little things.
    "Hopefully" doesn't cut it, the #1 most important thing in a PC first person shooter is mouse control, and in Bioshock it is completely BROKEN.

    I urge everyone to post here and PC-friendly mods please sticky this because as was shown buy the widescreen issue, Irrational is capable of listening to us if we speak out loudly enough.

  2. #2
    Join Date
    Mar 2007
    Location
    I'm from Brooklyn!!!
    Posts
    7,129
    *plugs in GFW 360 controller* sweeet...

  3. #3
    Join Date
    Mar 2007
    Location
    I'm from Brooklyn!!!
    Posts
    7,129
    Also, why the hell would anyone consider a moderator's post an official response?

    He's just a normal guy. Hell, I even named his kitten!

  4. #4
    Join Date
    Aug 2007
    Posts
    305
    Quote Originally Posted by BioShockWins View Post
    Also, why the hell would anyone consider a moderator's post an official response?

    He's just a normal guy. Hell, I even named his kitten!
    you are right, it's not exactly official but the closest thing we have gotten. If we could still edit our post i would do so. It still doesn't change anything, they need to fix this.

  5. #5
    Join Date
    Aug 2007
    Posts
    23
    Yeah, in the demo, I set the sensitivity to lowest and it worked fine on the menu but in game it's like LAWLALWLAWLLAWLLALWLAL LLAWLALWLAWLALWLAWLLAWLALWALWLALWLAWLALWLALWLA

    and luckily I have a razer mouse so I had to bring it down to the lowest setting but when I want to go to the menu I gotta go back up... not a big issue but it's annoying, can't people just make the sensitivity in menu the same as in game?

  6. #6
    Join Date
    Apr 2007
    Location
    U.K
    Posts
    886
    MX518 here - fine in other games, weird goings on in Bioshock *demo* (16:10 for me which amplifies it compared to when I played in 4:3).

    +1

  7. #7
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    8
    MX518 - Mouse sensitivity 1 and lowest dpi-setting just makes it barely playable.

    Please fix it.

    (German retail version running on Vista)

  8. #8
    Program Files\2K Games\BioShock\Builds\Release\Default.ini

    Find CaptureMouse=True and change it to False.

  9. #9
    Join Date
    Aug 2007
    Posts
    2
    Quote Originally Posted by KaoTiK View Post
    Program Files\2K Games\BioShock\Builds\Release\Default.ini

    Find CaptureMouse=True and change it to False.
    I'm also having the same problems. Also, the CaptureMouse edit does not work.

    Truly, this is unacceptable behavior for a FPS PC game. It is beyond comprehension that forced mouse acceleration could be overlooked if the PC version of the game was taken seriously by 2k.

    Just my 2c

  10. #10
    Join Date
    Aug 2007
    Posts
    18
    happening to me also and absolutely ruining the game for me. Sensitivity down to 1 and its still zoomin around!

  11. #11
    Join Date
    Aug 2007
    Posts
    21
    Same problem here. The wonky mouse acceleration is severely hampering my enjoyment of the game.

    I feel lucky compared to the folks who can't even install/play the game at all, but it's still plenty frustrating to not be able to hit what you need to hit because the bizarre and inconsistent mouse input.

    A couple of notes:

    Editing "Default.ini" doesn't work. Default.ini is only used the first time the game starts up, or after it crashes. The game settings are usually read from Bioshock.ini, which is located in your user directory.

    With Vista it's located in C:\Users\<your username>\AppData\Roaming\Bioshock

    With XP, I think it should be in C:\Documents and Settings\<your username>\AppData\Roaming\Bioshock (I don't have XP)

    That being said, Changing CaptureMouse to False did nothing for me, as did tweaking all the ReduceMouseLag options, etc.

    The most effective thing I've done is by editing "User.ini", found in the same directory as Bioshock.ini. The mouse speed is set in several instances of the same lines:

    Code:
    MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=2500.0
    MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=2500.0

    You can do a global search-and-replace of

    Code:
    Speed=2500.0
    with

    Code:
    Speed=1000.0
    which will slow the movement to a more reasonable speed. However, it doesn't make the acceleration any less terrible, and in fact, may make it more noticable because when it's slow, it's REALLY slow.

    It's really disappointing that there is clearly so much attention to detail in the game, yet the developers shrugged off one of the most fundamental elements of a PC first person shooter -- responsive mouse input.

    We should be spending our effort fighting the splicers, not fighting the controls. It ruins the immersion.

  12. #12
    Join Date
    Aug 2007
    Posts
    29
    Quote Originally Posted by Logy View Post
    Same problem here. The wonky mouse acceleration is severely hampering my enjoyment of the game.

    I feel lucky compared to the folks who can't even install/play the game at all, but it's still plenty frustrating to not be able to hit what you need to hit because the bizarre and inconsistent mouse input.

    A couple of notes:

    Editing "Default.ini" doesn't work. Default.ini is only used the first time the game starts up, or after it crashes. The game settings are usually read from Bioshock.ini, which is located in your user directory.

    With Vista it's located in C:\Users\<your username>\AppData\Roaming\Bioshock

    With XP, I think it should be in C:\Documents and Settings\<your username>\AppData\Roaming\Bioshock (I don't have XP)

    That being said, Changing CaptureMouse to False did nothing for me, as did tweaking all the ReduceMouseLag options, etc.

    The most effective thing I've done is by editing "User.ini", found in the same directory as Bioshock.ini. The mouse speed is set in several instances of the same lines:

    Code:
    MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=2500.0
    MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=2500.0

    You can do a global search-and-replace of

    Code:
    Speed=2500.0
    with

    Code:
    Speed=1000.0
    which will slow the movement to a more reasonable speed. However, it doesn't make the acceleration any less terrible, and in fact, may make it more noticable because when it's slow, it's REALLY slow.

    It's really disappointing that there is clearly so much attention to detail in the game, yet the developers shrugged off one of the most fundamental elements of a PC first person shooter -- responsive mouse input.

    We should be spending our effort fighting the splicers, not fighting the controls. It ruins the immersion.
    exactly how I feel and I applied the same "1000" tweak, it helped a little but the accel is still horrible.. please fix this asap

  13. #13

    Mouse lag, frame rate, shaders, VSync, oh my...

    I have edited every .ini file that came with. I have changed in-game settings--which do not stay changed, thank you very much. I have lowered the res on my laser mouse. I have updated my video (new nvidia forceware) and sound drivers. My machine exceeds minimum specs even with a P4 and XP. I have edited my msconfig and have virtually nothing else running. My first splicer combat encounter made the game run so slow and choppy I had to quit. And I have posted this and specs in the "outstanding PC issues" official thread. http://forums.2kgames.com/forums/sho...t=6642&page=34

    This is just killing me. Even the dialogue subtitles are way slow and lag behind the actual speech. I don't have time to appreciate the creepiness of the environment because by the time I catch up, it's all over. I am open to suggestions.

  14. #14
    Join Date
    Aug 2007
    Posts
    152
    Does anyone else find that when they first load up a level or a savegame, that there is no mouse acceleration, but once you've looked around a little bit it comes back in full force? That's what happens to me. And the first time was just after I tried altering the capturemouse to false, and I figured it worked, but then after looking around... pfft... seems very strange to me, how the mouse accelleration will be non-existent for a few seconds when entering a new level.

  15. #15
    Join Date
    Aug 2007
    Posts
    152
    Oh btw I have a G5, on the lowest DPI (bioshock only) and on sensitivity 1 in-game.

  16. #16
    Join Date
    Aug 2007
    Posts
    117
    Quote Originally Posted by Nishido View Post
    Does anyone else find that when they first load up a level or a savegame, that there is no mouse acceleration, but once you've looked around a little bit it comes back in full force? That's what happens to me. And the first time was just after I tried altering the capturemouse to false, and I figured it worked, but then after looking around... pfft... seems very strange to me, how the mouse accelleration will be non-existent for a few seconds when entering a new level.
    i noticed it as well. Im SORTA getting used to it but it would be nice if it was fixed.

  17. #17
    Join Date
    Aug 2007
    Posts
    18
    Is it happening to anyone who isnt using a Logitech mouse? I've heard a lot of people with G5's are experiencing this issue.

  18. #18
    Join Date
    Aug 2007
    Posts
    8
    Quote Originally Posted by BioShockWins View Post
    *plugs in GFW 360 controller* sweeet...
    Yeah, thanks ever so much for your invaluable input.

    Anyways, the mouse acceleration really does bother me quite a bit. The mouse capture setting definitely doesn't fix it, though it seem to make it somewhat more tolerable in a strange way. With the lowest in-game mouse setting, the menus cursor is so screwed up that if you don't move the mouse fast enough it won't even move. So, I set it one above and then drop my DPI from 2000 to 1000. It still bugs me all the time.

    It seems to me that Bioshock really was designed for the 360 with the PC as a complete afterthought. And it seems that everything they said to the contrary was a complete lie to sucker us in.

    I've found that using the FOV hack on a widescreen display slightly alleviates the severity of it all. No idea why though. Maybe I'm just imagining things.

  19. #19
    Join Date
    Aug 2007
    Posts
    29
    Quote Originally Posted by Nishido View Post
    Does anyone else find that when they first load up a level or a savegame, that there is no mouse acceleration, but once you've looked around a little bit it comes back in full force? That's what happens to me. And the first time was just after I tried altering the capturemouse to false, and I figured it worked, but then after looking around... pfft... seems very strange to me, how the mouse accelleration will be non-existent for a few seconds when entering a new level.
    yep, same here... though at first it seems slower than even the "base" sensitivity after looking around a bit, I'd have to check again to be sure.

  20. #20
    Join Date
    Aug 2007
    Posts
    8
    Quote Originally Posted by Dharma View Post
    Is it happening to anyone who isnt using a Logitech mouse? I've heard a lot of people with G5's are experiencing this issue.
    I have a Razer Copperhead, which, like the G5, is a 2000 DPI laser mouse. I think it even uses the same camera as the G5.

  21. #21
    Join Date
    Aug 2007
    Posts
    29
    Quote Originally Posted by Dharma View Post
    Is it happening to anyone who isnt using a Logitech mouse? I've heard a lot of people with G5's are experiencing this issue.
    razer deathadder here.

  22. #22
    Join Date
    Aug 2007
    Posts
    8
    Quote Originally Posted by zodduska View Post
    yep, same here... though at first it seems slower than even the "base" sensitivity after looking around a bit, I'd have to check again to be sure.
    Yeah, it's really weird. You first load into a level and it moves much more slowly but after you move the mouse around a bit it's back to the regular suck. The fact that *any* of this actually made it past QA makes me think that all of the 2K Australia folks were playing it with a 360 controller. Effing lame.

  23. #23
    Join Date
    Aug 2007
    Posts
    18
    Quote Originally Posted by Logy View Post
    Same problem here. The wonky mouse acceleration is severely hampering my enjoyment of the game.

    I feel lucky compared to the folks who can't even install/play the game at all, but it's still plenty frustrating to not be able to hit what you need to hit because the bizarre and inconsistent mouse input.

    A couple of notes:

    Editing "Default.ini" doesn't work. Default.ini is only used the first time the game starts up, or after it crashes. The game settings are usually read from Bioshock.ini, which is located in your user directory.

    With Vista it's located in C:\Users\<your username>\AppData\Roaming\Bioshock

    With XP, I think it should be in C:\Documents and Settings\<your username>\AppData\Roaming\Bioshock (I don't have XP)

    That being said, Changing CaptureMouse to False did nothing for me, as did tweaking all the ReduceMouseLag options, etc.

    The most effective thing I've done is by editing "User.ini", found in the same directory as Bioshock.ini. The mouse speed is set in several instances of the same lines:

    Code:
    MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=2500.0
    MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=2500.0

    You can do a global search-and-replace of

    Code:
    Speed=2500.0
    with

    Code:
    Speed=1000.0
    which will slow the movement to a more reasonable speed. However, it doesn't make the acceleration any less terrible, and in fact, may make it more noticable because when it's slow, it's REALLY slow.

    It's really disappointing that there is clearly so much attention to detail in the game, yet the developers shrugged off one of the most fundamental elements of a PC first person shooter -- responsive mouse input.

    We should be spending our effort fighting the splicers, not fighting the controls. It ruins the immersion.
    This is probably the best im going to get id say. Did improve things and now ill probably start playing it again. Thank you for that.

    Acceleration is till ridiculous but its better than nothin

  24. #24
    MX518 Lowest possible DPI and Sensitivity at 1, impossible to aim. Impossible to hack.

  25. #25
    Join Date
    Aug 2007
    Posts
    305
    I even tried setting windows to 3/11 sensitivity, essentially 100 dpi, and the the acceleration was still nuts.

  26. #26
    Someone needs to make the first BioShock mod and include a way to disable the accel

  27. #27
    Join Date
    Aug 2007
    Posts
    4
    I found that changing the following values in the Bioshock.ini file to false helped to improve the smoothness of mouselook. Also, disabling the default anisotropic filtering mode from 4 (default) to 1 (minimum) helped to improve the framerate, and subsequently the mouselook smoothness.

    XP/DX9
    [D3DDrv.D3DRenderDevice]
    ReduceMouseLag=False
    DoubleBufferMouseLag=False
    LevelOfAnisotropy=1


    Vista/DX10
    [D3DDrv10.D3DRenderDevice10]
    ReduceMouseLag=False
    DoubleBufferMouseLag=False
    LevelOfAnisotropy=1


    With these settings, I find a sensitivity of around 2 to be sufficient. If you need more granularity, you can adjust the value manually as follows:

    [ShockGame.ShockUserSettings]
    MouseSensitivity=2.125000

  28. #28
    Join Date
    Aug 2007
    Posts
    305
    My framerate is 60+, I have a very PC. I have tried the settings you speak of and they do nothing to kill the acceleration. Aniso filtering also has nothing to do with acceleration. If your framerate is ☺☺☺☺ of course lowering it will help, but smoothness and acceleration are not the same thing.

  29. #29
    Join Date
    Aug 2007
    Posts
    305
    very god PC* (wtb edit)

  30. #30
    Join Date
    Aug 2007
    Posts
    4
    Quote Originally Posted by shiznit View Post
    Aniso filtering also has nothing to do with acceleration. If your framerate is ☺☺☺☺ of course lowering it will help, but smoothness and acceleration are not the same thing.
    I understand that, and wasn't trying to claim otherwise. Nevertheless, I do find the issues interrelated, at least with my setup.

    The anisotropic tweak was just another contributing factor to general mouselook perception and feel. This may be the case for other users as well.

  31. #31
    Join Date
    Aug 2007
    Posts
    17
    Another here for the mouse fix please.

    Menus screens / hacking too slow, and in game too fast even on 1 sens.

  32. #32
    Join Date
    Aug 2007
    Posts
    305
    typing in the dark w/o edit sucks, i keep messing up. anyway, you are right it helps the framerate and the mouse feel, i was just trying to keep this focused on the acceleration, we want it fixed.

  33. #33
    Quote Originally Posted by BioShockWins View Post
    Also, why the hell would anyone consider a moderator's post an official response?

    He's just a normal guy. Hell, I even named his kitten!
    It seems pretty official when they can ban you from the forums when you aren't attacking anyone, spamming in multiple posts, or creating a negitive environment. Yeah ...

    About mouse settings I have mine almost identical to my CSS mouse settings.

    in the defuser.ini i set this and it helped a ton

    MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=1300.0
    MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=1300.0

  34. #34
    Join Date
    Aug 2007
    Posts
    305
    thanks a lot, i can actually aim now. I dont feel as much acceleration anymore and the cursor is actually usable.

  35. #35
    Join Date
    Aug 2007
    Posts
    305
    btw i entered your settings in both user.ini and defuser.ini.

  36. #36
    Join Date
    Aug 2007
    Posts
    305
    still not quite right, too slow when you are barely moving the mouse and still accelerates. But it is way better than having to use setting 2 to keep the cursor working.

  37. #37
    Join Date
    Aug 2007
    Posts
    305
    Why was this thread moved from "general" to "technical support? This is not a technical issue, the problem is not on our computers. this is a DESIGN problem, the mouse support need to be overhauled.

  38. #38
    Join Date
    Aug 2007
    Posts
    305
    Still no response...

  39. #39
    Quote Originally Posted by shiznit View Post
    We really need a consolidated thread for this so I attempting to start one. The forced and completely insane mouse acceleration is ruining this game for me and for many others. I am down to sensitivity setting 1 (and i only use a 400dpi mouse!), putting up with the messed up cursor, aiming is still to fast and all over the place. This is in the retail copy btw, I know I said I would not buy the game until this was fixed but I gave in after playing a couple of levels on a friend's xbox, it is really is that good, reminds me of Tie Fighter when i was a kid and the feeling of awe I had while playing that game. However, I have 2 weeks to return it and I will do so if we don't hear official word from Irrational about mouse control.

    I have tried the 3 possible mouse settings in bioshock.ini and nothing works, the mouse feels like its using a 360 analog acceleration curve that was just hacked into the mouse code as an afterthought. I urge everyone to listen to the podcast about the PC version on Cult of Rapture, in which 2k australia devs. say how they know how to make a pc shooter and how it has "tight controls" and how it lives up to the standards set by other popular PC shooters. All other pc shooters have proper mouse contol that that allows you to aim accurately once you rid windows of all acceleration, set up your mouse properly, and settle on a good sensitivity (mine is 30cm/360).

    for reference my mouse is MX510, standard windows driver, "pointer precision " OFF, CLP mouse fix (kills all acceleration by editing registry), 1:1 windows speed (6th notch, if you dont believe or don't know about this go here http://www.overclock.net/computer-pe...on-guide.html).

    If you haven't gone through this process of getting rid of all acceleration, then you have been playing with it all along and probably don't even notice the problem, so please dont troll here with how "your mouse works fine". This is serious for those of us who rely on precise, unaccelerated or interpolated mouse control.

    If you have gone though this process and play with true 1:1 mouse movement, you play by muscle memory, and can react instinctively. If I hear someone behind me i know that if move my mouse 15cm to either side i will do a perfect 180 turn every time. When you play this way for a while it becomes second nature and it is impossible to go back.

    The broken mouse control makes it impossible to play Bioshock enjoyably. It goes against everything we were promised by the devs in the podcast about the PC version.

    The only official response that we have received so far is this:


    "Hopefully" doesn't cut it, the #1 most important thing in a PC first person shooter is mouse control, and in Bioshock it is completely BROKEN.

    I urge everyone to post here and PC-friendly mods please sticky this because as was shown buy the widescreen issue, Irrational is capable of listening to us if we speak out loudly enough.
    Buy a a razer mouse you can turn down the sensitivity quite a bit im playing bioshock on pc and dint even know this is a problem until i read ur post

  40. #40
    Join Date
    Aug 2007
    Posts
    305
    I shouldn't have to replace a mouse that has worked flawlessly for years in every other game.

Page 1 of 15 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •