Results 1 to 9 of 9

Thread: Game keeps reverting gfx and sound settings to default.

  1. #1
    Join Date
    Aug 2007
    Posts
    4

    Question Game keeps reverting gfx and sound settings to default.

    Yo.
    Every 2 or so times i start Bioshock (PC) i find my graphics settings, and resolution have been reverted to default, and my EAX and speaker settings have changed.

    Anyone else have this problem, and/or know how to fix it?
    Thanks.

  2. #2
    Quote Originally Posted by Raz0rx View Post
    Yo.
    Every 2 or so times i start Bioshock (PC) i find my graphics settings, and resolution have been reverted to default, and my EAX and speaker settings have changed.

    Anyone else have this problem, and/or know how to fix it?
    Thanks.
    If that's the only problem you're having then congratulations.

    This also happened to me constantly. But I was also getting game crashes all the time. When it crashed, it reset the options.

    Now that I turned off the culprit (high detail shaders) the game doesn't crash, and the options don't reset.

    Of course, if you're not getting crashes, but your options keep reseting, well then that's a different issue.

  3. #3
    Join Date
    Aug 2007
    Posts
    8
    This happens when the game crashes.
    When you start the game it creates a file called running.ini in the directory
    C:\Documents and Settings\username\Application Data\Bioshock
    When you exit the game cleanly this file is removed. However when the game crashes this file remains and the next time you start it, it sees the file, assumes there was a problem with the settings that caused the crash and so reverts to the defaults.

    To get around this just manually delete running.ini before restarting the game

  4. #4
    Join Date
    Aug 2007
    Location
    NS, Canada
    Posts
    43
    Good tip. This happened to me once and deleting the running.ini would be a much quicker way to get your settings back than making sure everything is set as you like it. Thanks for that, licenced.

  5. #5
    Join Date
    Aug 2007
    Posts
    8
    Another good idea is to take a copy of the file Bioshock.ini from the same directory - then if you ever do forget to delete running.ini before restarting, just quit and replace the Bioshock.ini file that the game has just created containing all the defaults with your copy to get your settings back

  6. #6
    Join Date
    Aug 2007
    Posts
    11
    To resolve the problem copy the bioshock.ini in the "C:\Users\Marc Okunnu Jnr\AppData\Roaming\Bioshock" and rename it to default.ini. Now browse to the "D:\Program Files (x86)\2K Games\BioShock\Builds\Release" directory and rename the default.ini to defaul.ini backup. When that is done compy the default.ini from the "C:\Users\Marc Okunnu Jnr\AppData\Roaming\Bioshock" directory to the "D:\Program Files (x86)\2K Games\BioShock\Builds\Release" directory. Now if ever it should crash it should never revert to anything other than your desired play setting.

    All the best

  7. #7
    Join Date
    Aug 2007
    Location
    NS, Canada
    Posts
    43
    As a note to Vista (64-bit) users, I believe the path to the .ini files would be: C:\Users\[username]\AppData\Roaming\Bioshock

  8. #8
    Join Date
    Aug 2007
    Posts
    3
    Happens to me too - every time I load the game, I enable vsync. I quit, I load the game again, and vsync is disabled. And the game hasn't crashed once.

  9. #9
    Join Date
    Aug 2007
    Posts
    4
    Thanks Jaylumx.
    I haven't had a single other issue with Bioshock so far... no crashes, no nothing.
    Runs flawlessly!

    Except for this minor issue.
    I'll give it a shot tomorrow after work (need to sleep now) and will report back on how it goes for me.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •