Results 1 to 6 of 6

Thread: Installation woes with Civ 4 and windows seven:

  1. #1
    Join Date
    Mar 2011
    Posts
    2

    Installation woes with Civ 4 and windows seven:

    I recently upgraded my computer: new motherboard, CPU, Graphics card, Windows 7, and I'm getting around to reinstalling the usual suspects, and i've encountered a snag with Civ 4. I want to say i've got one of the original pressings of Civ 4. it's been so long that i don't rightly remember. regardless, i've Installed the program (v1.09), and then i go to install the patch (v1.74) so i can get to installing BTS, and I get the following error message:

    "setup has detected that version 1.09.000 of Sid Meier's Civilization 4 is already installed

    This setup is not compatible with this version.

    You will have to uninstall the previous version before installing this version."
    i've tried to install BTS over an unpatched vanilla Civ 4, but i get an error message that tells me the patching failed.


    please halp?

  2. #2
    Join Date
    Sep 2010
    Location
    Support
    Posts
    1,791
    Hi,

    When 1.09 is installed and it is one of the older versions we always advised sequential patching - 1.61 and then 1.74.

    You can get both of these from firaxis.com

    However, if you are going to install BtS on top of it, just install the 1.61 update and then go for BtS on top of that. This should work for sure.

    If not, do let me know. I could pre-empt a DirectX9 issue but it doesn't show up as regularly as it did with Vista.

  3. #3
    Join Date
    Mar 2011
    Posts
    2
    that seems to have worked. thanks.

  4. #4
    Join Date
    Sep 2010
    Location
    Support
    Posts
    1,791
    No worries

    Any further issues just post it in here

  5. #5
    Join Date
    Aug 2011
    Posts
    3

    Civ 4 Complete will not install on Windows 7 64bit

    Hello,

    I recently purchased a new computer (acer aspire am3970) running Windows 7 Home Premium 64 bit. I also recently purchased the Civ IV Complete dvd, and despite my very best efforts the game will not install.

    I have attempted every suggested fix I can find. I have tried running setup.exe in both normal and admin mode for each available compatibility mode. I have tried the express install in normal and admin mode, I have tried custom install saving to desktop and to a new "Games" folder in Drive:C. Each and every time there is an installation error about 2/3 through the installation process.

    I have run through the DirectX installation included with the dvd. In a desperate act, I even purchased the game as a download from amazon hoping that the installation would be easier, but the installation errors were the same.

    I have screenshots of several of the error messages if anyone is interested in seeing them (i'm not sure how to post them in this message). The errors are usually slightly different, but occur around the same time during the installation process.

    If I can provide any other information that might help diagnose my problem, i am happy to provide it. Any help will be very much appreciated!

  6. #6
    Join Date
    Aug 2011
    Posts
    3
    So, instead of screenshots I've jotted down several of the errors that keep popping up. Maybe these will make sense to someone.

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\Assets\Art\Interface\Buttons\War13a90.rra
    Error: 5

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\CVGameCoreDLL\Boost-1.32.0\Include\Boost\MP\Aux_\Preprocessor\Ext_3ed5 .rra
    Error: Access is Denied

    Feature: Default Feature
    Component: Civ4 Component
    File: Beyond The Sword\Assets\Art\Units\WarElephants_MiddleEast\War Ed432.rra
    Error: Access is Denied

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\CVGameCoreDLL\Boost-1.32.0\Include\Boost\MP\Aux_\Preprocessor\Array\Re pl9c6f.rra
    Error: Access is Denied

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\CVGameCoreDLL\Boost-1.32.0\Include\Boost\MP\Aux_\Preprocessor\Arit2da6 .rra
    Error: Access is Denied

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\Assets\Art\Leaderheads\WinstonChurchill\C hurbd58.rra
    Error: Access is Denied

    Feature: Default Feature
    Component: Civ4 Component
    File: BeyondTheSword\Mods\FFH Age of Ice\Assets\Art\Units\FallFromHeaven\GiantSpider\Sp id2899.rra
    Error: 5

    Feature: Default Feature
    Component: Civ4 Component
    File: Warlords\CVGameCoreDLL\Boost-1.32.0\Include\Boost\MPL\Multiset\Aux_\Coun1843.rr a
    Error: Access is Denied

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •