Results 1 to 3 of 3

Thread: Civilization V will not launch in Steam

  1. #1
    Join Date
    Apr 2011

    Civilization V will not launch in Steam


    I bought Civilization V yesterday, and have spent all the time since trying to get it to work properly. I've tried installing both with the CD and through a steam download.

    Steam works for other games, but for some reason when I double click on Civ V it just tries to load then the steam dialog screen disappears and nothing happens. Using the task manager, I've checked that it is trying to load but stops for some reason.

    I've also checked, and no file is being created under Documents/My Games...

    I've already emailed Steam, and got the following response.


    A staff member has replied to your question:

    Hello, Thank you for contacting Steam Support. If you are running in Windows Vista or Windows 7, please completely exit Steam, and right-click on the shortcut which you use to launch Steam and select "Run as Administrator." If you are running in Windows XP, take the following steps: 1) Exit Steam. 2) Go to the "Start" menu, select "Run", type "regedit" and click "OK". 3) Navigate to the following registry key: HKEY_CURRENT_USER\SOFTWARE\VALVE 4) Right click and select "Permissions" 5) Check the "Allow" boxes for "Admin" and "System" for both "Full control" and "Read". The remaining steps apply to *all* versions of Windows. Then, verify the game's files at least once: Title: Verifying Game Cache Files (GCF) Link: NOTE: There may be files that fail to validate. This is normal and can be ignored. If the issue persists, you may also need to manually run secondary installers required by this game. Exit Steam entirely. Browse to your Civilization V installation folder (Usually C:\Program files\Steam\Steamapps\Common\sid meier's civilization v\) Run the following installers: ...\Steamapps\Common\sid meier's civilization v\VCRedist\vcredist_x86.exe ...\Steamapps\Common\sid meier's civilization v\DirectX\DXSetup.exe Reboot your computer and test the issue again. If you continue to have difficulty, and you are running Windows Vista or 7, please also run the following installer (if you are using Window XP you may skip this step): ...\Steamapps\Common\sid meier's civilization v\DirectX\D3D11Install.exe Reboot once more and test the issue again. Should the error persist, and you are running the game on Windows Vista or Windows 7, attempt to run the game in an alternate DirectX mode. On launch, the game should give you two options: -"Sid Meier's Civilization V DirectX 9" -"Sid Meier's Civilization V DirectX 10 & 11" Please test both of these options and check if the problem exists in both. If the issue persists, further support for this title is handled by a third party support department - please follow the instructions in the link below to contact the support provider to troubleshoot this issue: Title: Sid Meier's Civilization V Link:

    Anytime you wish you can view your question online:

    This advice didn't solve the problem. I'd appreciate any help you guys could give me!

    My system specs...
    Windows 7 64 bit
    Aspire M3802
    Intel Core 2 Quad CPU Q8300 2.5 GHz
    6144 MB RAM
    ATI Radeon HD 4300/4500 Series
    Realtek HD Audio

  2. #2
    Join Date
    Sep 2010
    It would be a good idea to check this without your security software running. A good few of them terminate the process right from the off.

    Quit out of Steam, disable anti-virus/firewall, log in to Steam, try it again.

    You updated the drivers for the graphics card?

  3. #3
    Join Date
    Jul 2012
    I have the same problem. When I first bought the game it worked fine, now it will not launch. Steam is junk.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts