Results 1 to 7 of 7

Thread: Freeze everytime in loading screen. Tried everything!

  1. #1
    Join Date
    Sep 2007

    Freeze everytime in loading screen. Tried everything!

    I didn't read the whole 130 page "problem thread" but I think my bioshock is going to shelf to gather dust for awhile now when waiting a patch. But anyway, one last chance...
    My problem is when loading a game or sometimes new level, game freezes in loading screen and I have to ctrl+alt+del to exit it. And when it's freezed, every setting come back to default. It freezes everytime single time when loading a game in 1680x1050 resolution, but sometimes I can get it to work when loading savegame in default settings before I delete user and temp folder. I have thus far 99.9999-100% reliable PC (always on and doing work). One crash per few months or so.

    Gainward BLISS 8800GTS 320MB
    Gigabyte GA-965P-S3 motherboard
    Core2Duo E6300
    2GB Corsair XMS TwinX Matched DDR2
    16bit plug&play USB soundcard with Burr-Brown Japan PCM2702 DAC
    Antec TruePower 550W 2.0
    ACER AL2216WSD
    WinXP Pro 32bit

    CPU, GPU and Chipset all are watercooled so temps are not a problem. Voltage rails are all ok.
    What is a mystery to me, the demo ran flawlessy. I actually installed it again and verified it works 100%!

    What I've tried:
    Installed game multiple times to different drives.
    Configured swapfile to install drive.
    Upgraded mb bios.
    Upgraded GPU drivers.
    Upgraded motherboard drivers.
    Upgraded newer version visual C++ -this caused application error.
    Upgraded Directx9 (august)
    Disabled/enabled directx audio acceleration
    Disabled/enabled GPU write combining.
    Deleted savegames and "Documents&settings/username/bioshock" folder
    Various bios settings/various MB bioses.

    I think the problem could lie in videocard as you know there's this "NVIDIA memory bug" in every 8800GTS (320MB) cards. In my case this problem is really bad in certain games and worst cases are Stalker, Quake4 and Oblivion. But in bioshock it's completely disappeared!! At least when I'm forced to play same level almost all the time.

    Any help is greatly appreciated! If it helps there's this weird problem when exiting bioshock, my desktop colors go "washed out" ie somewhat brighter and stay even if I default them in NVIDIA control panel. I use lower gamma in nvidia control panel because my 22" ACER AL2216WSD is too bright. Has anybody else this problem?

  2. #2
    Join Date
    Sep 2007
    I have problems on the xbox 360 loading the Hepaestus level...same problem, different system...

    Do you take alot of research pictures? I have a funny feeling that this results in big save files which then causes a hang....


  3. #3
    Join Date
    Sep 2007
    No, I haven't taken any pictures. I have about 15 savegames. I passed medical pavillon while ago. ..I can't really play when trying to solve this problem.

  4. #4
    Join Date
    Aug 2007
    At my desk
    Hello L7R,

    Thanks for the detailed report about the problem you are having. You seem to have done an extensive amount of troubleshooting already, however I do have a few more suggestions (Which you may or may not have tried already).

    Compatablity Mode

    Try running the game in Windows 2000 Compatability mode using the following instructions :
    - right click on the shortcut for the game
    - left click on properties
    - click on the Compatability tab
    - tick the box called "Run this program in compatability mode for"
    - select Windows 2000 click on apply
    - click on ok

    See what happens.

    Graphical options

    You mentioned about this happening at the high resolution you are using, but you did not mention if the problem happens at lower resolutions with the graphical options turned off.

    The Gainward 8800 card

    Its possible this type of card you have is already factory overclocked, I suspect the ExperTool on the following website will allow you to change some of these settings

    Try using the ExperTool on the video card and see if there is any particular option which may allow the game to work.

    Saved games

    Is this just the single saved game which causes this problem?

  5. #5
    Join Date
    Sep 2007

    First, thanks Richard for help. I even tried to "underclock" my videocard -unfortunately no avail. And tried win2000 compatibility mode.
    Some news about this problem -I made some progress, albeit little... Seems my problem lies in my videocard/drivers. As the game freezes in loading screen (or just after I see a picture), I decided to wait and see If I got any error message or something. After about 5 minutes I actually get blue screen saying something like (forgive me my bad english) infernal loop caused by nv4_disp. Then I tried again and now I got just a message that bioshock has crashed-do you want to inform microsoft bla,blaa. Everytime after this ctd, my desktop goes 4bit(!) colors in 800x600 and cannot change to any other resolution or color. Sometimes there's also a BSOD mentioning nv4.dll and suggestion to upgrade my drivers.

    Now, Richard: I actually CAN play the game (load any save I want) if I delete bioshock.ini, user.ini and running.ini. If I don't do that (after the crash or BSOD), the game reverts to default settings but won't load any savegame after restart. After deleting those files I can change whatever settings I want and continue loading any savegame. Then I can play how long I want and load and save (or quicksave) until next level loading screen or restarting the game. But quite often after playing inside same level and then restarting, the game loads without problem, and thats weird?!

    I have to admit I'm little disappointed, but not Bioshock but NVIDIA. That slowdown bug never appears in hardware tests but even in high price, many "average-Joe" buy this card and never realize the framerate drops 50-80% after awhile. If you don't know that, you can buy faster choosing 8600 or even entry-level videocard, ati or nvidia.
    I play on high resolution, so I think it affects how long I can play and actually in oblivion, stalker or quake4 -how far I could travel. Then having to switch to desktop and back. I'm pretty sick hitting alt-tab in every 1-10 minutes depending a game. Really affects immersion I must say! I've been waiting a proper fix to this d**n videocard for about half a year ...I'm pretty headstrong, but most of Finnish people are.

    sorry my ankward english, I'm not 6yo!

  6. #6
    Join Date
    Sep 2007


    Installing new NVIDIA beta drivers 163.67 solved my problem . No more nv_disp errors, nomore bluescreens whatsoever. No more infernal loops, and no more crashes to desktop! I also removed all my unnessesary USB devices and hubs -don't know if that helped also?

    I thought I never gonna say this; thank you nvidia!

    ps. It would be very nice if we could edit our posts, so this could help everyone with same problems. I would like to add "solved" to the tittle of the topic.

  7. #7
    Join Date
    Jan 2009

    I have same Bioshock problem.

    System specs.
    OS:Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1
    CPU:AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ (2 CPUs), ~2.7GHz
    MB:Biostar~A740G M2+
    Graphics:ATI Radeon HD 3600 Series
    Memory: 1787 MB(total)
    Shared: 1279 MB
    Dedicated: 508 MB
    RAM: 3070MB RAM (2mb off)

    I have the same problem. I can get into the main menu of the game, change settings, but when i try to start the game, i get to the loading screen and on the third picture that pops up, it totally freezes. I sure that my computer is just fine. I can play COD World at War, Left 4 Dead, UT2004, Vegas 2, Crysis and a ton more games. Do you have any idea why this game freezes?
    Thanks for the help.
    Also ive tried the Windows Compatibility modes but they dont even run the game(that might just be vista). Also my graphics drivers are updated, and my resoultion on all my games is 1680-1050 and it works just fine.
    Last edited by Darco3; 01-03-2009 at 03:06 PM. Reason: forgot some things...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts