Results 1 to 4 of 4

Thread: Bioshock 2 x64 Windows 8 ?

  1. #1
    Join Date
    Aug 2012

    Bioshock 2 x64 Windows 8 ?

    Im running the MDSN version of W8 x64. When I launched B2 it asked for key, which I pasted into dialogue and it said it was registering.

    It seemed to reg ok but would not start.

    I have tried to launch it, but it does not start at all.

    Tried running the exe in compatibility mode for Windows 7, but no luck -

    C:\Program Files (x86)\Steam\steamapps\common\BioShock 2\SP\Builds\Binaries


    "ordinal not found"
    Also updated ATI drivers to latest & catalyst, but this had no effect either.

    Has anyone had any luck running it in this OS?

    Is there a guide somewhere on where to find the log to see what is going wrong with the program launch?



  2. #2
    Your XLive.dll may be borked. Its a long shot, but could you try removing it from the mentioned folder and install GFWL client anew? I'd move the file instead of deleting it just in case though.

  3. #3
    Join Date
    Aug 2012
    hello everyone,

    i have problem with biochock 2 on windows 8 rtm pro x64. it crashes old the time when i try to run. i don't know why it happenes but it just craches. i just take a ss what happenes on my pc, it says "Bioshock 2 has stopped to run, Windows searching to solve for problem"

    my system is;

    CPU Type DualCore Intel Core 2 Duo E4400, 2000 MHz (10 x 200)
    Motherboard Name Asus P5G41T-M LX (2 PCI, 1 PCI-E x1, 1 PCI-E x16, 2 DDR3 DIMM, Audio, Video, Gigabit LAN)
    Motherboard chipset Intel Eaglelake G41
    Ram 4096 MB (DDR3-1333 DDR3 SDRAM)

    Display Card Radeon X300/X550/X1050 Series (Microsoft Corporation - WDDM) (256 MB)
    3D-Hızlandırıcı ATI Radeon X1050 (RV370)
    Philips 107E/S/T7 [17" CRT] (AU0633002396)
    Realtek ALC887 @ Intel 82801GB ICH7 - High Definition Audio Controller [A-1]

  4. #4
    Just contributing to the thread here. I installed BS2 from GFWL on Windows 8 with all the DLC add-ons, too. The install went fine, and afterward attempted to start the game, with immediate crash. All that would happen is the screen would blink and then come back to me at the desktop. I then downloaded the 1.5 patch, and installed it, and everything ran fine after that. I believe there is a SecureROM problem (or incompatibility with Win8) that is fixed in the 1.5 patch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts