Results 1 to 5 of 5

Thread: CIV V Multiplayer Disconnects after each turn

  1. #1
    Join Date
    Sep 2012

    CIV V Multiplayer Disconnects after each turn

    I hope 2k and Firaxis is aware of this bug and are working to patch this:

    CIV V disconnects every player in our session, and we need to invite everyone back and then again, after one turn it disconnects. It is really hard and annoying to keep playing like this.
    The most annoying thing is that the disconnecting starts to happen about 800bc-100ac. Meaning that we have just got our civs to flourish nicely when this starts to occur.

    We have tried different people hosting the game but the same thing still happens.
    We tried both dx9 and dx11 versions. We all have high speed internet connections.

    We all have the Steam GOTY version of the game.

    It is really a shame that this great game is so broken. Does anyone know how to fix this?
    I tried searching the forums and google, but found nothing.

  2. #2
    Join Date
    Jun 2010
    Lancaster, UK
    Well, it's not a general bug, because it's sure not happening to everyone.

    There are so many variables that it's very hard to track down where a problem like that is coming from, when it happens to just a few people.

  3. #3
    Join Date
    Sep 2012
    Yes, thats true.

    I just ran thru some of the save games we made and I noticed that most of the games had the following rules:
    - No dlcs
    - Quick Pace
    - No quick combat
    - No Barbarians
    - Standard size world
    - 3 Player + 2 AI's, everybody in different team

  4. #4
    Join Date
    Jan 2013
    Actually it does happen to everyone assuming a certain game configuration is selected.

    To reproduce the fault create a multiplayer game with the following characteristics;

    huge map
    2 human players
    6 or more AI players

    Play the map until one of the AI players hits the industrial age.

    You will start experiencing random disconnects during the "Processing AI" phase.

    If you persist and keep reloading from saves and reconnecting, eventually you will disconnect at every turn (as more AI players reach industrial age).

    I have a theory that the reason this happens is that while the host is struggling to process the AI using a single CPU thread (and therefore a single CPU core) the rest of the game (internally) basically "hangs" because it can't get access to enough CPU cycles. This includes the in-game network listener process. Consequently the client PC will be sitting there saying "Hello? Are you still there?" and will be getting no response from the host because it is incapable of responding while it is busy processing the AI turn. The end result is that the client eventually gives up because from its perspective the host is not contactable so it just disconnects.

    Unfortunately all this means that you could throw Civ 5 at a four socket quad core beast and it would still fail in this way. I don't think it will ever be fixed because the problem lies in the core architecture of the game itself.

    The game really shouldn't be advertised as having multiplayer because the MP is basically unplayable.

  5. #5
    Join Date
    Jan 2013
    Me and the wife are experiencing this problem when playing on Local Network also.
    First it was after a long time (many turns with only city states and barbarians save us too) that the dissconnects started to occur.
    But now we are experiencing problems when running a small game without anyone but us.
    That is, two players on a skirmish map. Still the disconnect occurs.
    And to make matters worse, we only get a small notification, and then the AI takes over for the remote player.
    That is almost more annoying since when we reconnects the AI have always screwed with plans.
    I run on a Core 2 Duo, and she is on a i5 laptop, and it is bought through steam.
    It is a great game, but multiplayer is only frustrating at this point, so please fix this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts