Results 1 to 5 of 5

Thread: Fix for key bind error

  1. #1

    Fix for key bind error

    I've noticed a few people having the same issue I had with being unable to reassign keybinds after starting the game with a controller connected.

    http://forums.2kgames.com/showthread...an-t-bind-keys
    http://forums.2kgames.com/showthread...reset-quot-%29
    http://forums.2kgames.com/showthread...e-key-bindings

    After trying everything I could think of to fix this problem, including deleting the game and all configs and reinstalling, which didn't work, I finally came up with a solution and figured I'd sign up and post it here for others having the same issue.

    It appears that the game saves something to the Steam Cloud that needs to be reset. I don't know if this is the easiest way to achieve this, but it's what worked for me. Also I did this a couple of hours ago so I hope I remembered it right, but try this at your own risk, I'm not responsible for damage, etc.:

    - Disconnect any controllers
    - Open Steam and disable Cloud Syncing - "Steam > Settings > Downloads + Cloud"
    - Find the directory that contains the local copies of Bioshock Infinite's synced files, which should be "Steam/userdata/<ID number>/8870/" (8870 is Bioshock Infinite's AppID#)
    - I'm not sure which file specifically is causing the error, but as I hadn't played far yet and didn't have saves beyond the first checkpoint to worry about, I just deleted all the contents. If you have saves you want to keep, you'll have to make your own decision.
    - I'm not sure if this is necessary, but I also deleted the game's config directory "C:\Users\<username>\My Documents\My Games\Bioshock Infinite\" (Win 7) It will recreate this directory when you start the game.
    - Run Bioshock Infinite (without re-enabling Steam Cloud yet)
    - The game should say that it couldn't find a profile and will play as if it's the first time, asking you to set the brightness. At this point I was finally able to edit my keybinds.
    - Quit the game and re-enable Steam Cloud. When you try to run the game next you'll get a Steam popup saying that the Cloud files don't match and an option to either download the Cloud files to your computer or upload your computer's files to the Cloud. Choose the latter.*
    - Play the game!

    * I just tried to repeat this whole process to make sure I'm explaining it right and I didn't get the sync prompt, but it may be because I'd already fixed the initial problem, so the sync files now matched, I'm not sure.

    Hopefully I've explained it right and it helps someone. Now to finally go play the game...

  2. #2
    Join Date
    Feb 2010
    Posts
    11
    mate, you rock. i now have custom key bindings excellent

    i don't use the cloud, so i just disregarded those steps (but i did empty the remote 8870 folder)

    after you have set up your keybinds, you might want to go to nnn\Documents\My Games\BioShock Infinite\XGame\Config\XEngine.ini you can edit AllowJoystickInput=1 to AllowJoystickInput=0 so you won't have to unplug your joystick beforehand each time

    thanks once again Bantha Fodder!

  3. #3
    No probs, glad it worked!

    Yeah, I've made that change too now, thanks

  4. #4
    Join Date
    Mar 2013
    Posts
    5
    Hmm, I've noticed you say \XGame\Config\XEngine.ini ....all my files are "DefaultEngine" & "DefaultUI" etc. I wonder if this is the source of my issues? Your solution didn't resolve my key binding problems unfortunately.

    **Edit** I was in my steam directory, not the folder under MyDocuments...derp...still can't get this damn game to accept new key bindings! RAWR!
    Last edited by Jonkin; 03-27-2013 at 09:20 AM.

  5. #5
    Join Date
    Mar 2013
    Posts
    4
    Tried everything you said, couldn't get it to work. I went as far as unplugging my controllers with the pc off, starting the pc and closing the logitech profiler, no luck. Decided since I was this far I'd uninstall the game , delete the config directory and the profile.bin in the 8870 directory and re-install the game. I went straight to the keyboard options and was able to change the key bindings! HOORAH! I am now playing in 1999 mode and couldn't be happier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •