Results 1 to 2 of 2

Thread: Crashing on 'loading' screen: Civ 5 & BNW

  1. #1

    Crashing on 'loading' screen: Civ 5 & BNW

    Nearly every time I open Civ 5 from Steam, it shows a loading screen for about 5 seconds and then crashes back to the desktop. I used to be able to play Civ 5 on this laptop, about a year ago. Recently I tried again, having purchased a Brave New World, but started having this problem. On just one occasion (last night) it loaded up and played just fine. I saved my game, quit the program, and now it will not start up.

    I've tried every fix discussed on the various forums, including:
    - deleting the video files,
    - installing the cvredist_x86.exe, DXSetup.exe, D3D11Install.exe
    - deleting the cache from the 'my games' folder
    - redownloading the video drivers for my laptop
    - reinstalling the game
    - verifying the game cache within steam

    My Windows username includes no unusual characters.

    I should mention that my laptop is a Sony VPCZ21M9E and has a dock which includes an AMD Radeon HD 6650M graphics card, whilst my laptop uses Mobile Intel HD Graphics. However, it makes no difference whether I try loading the game with the dock or without.

    I'd appreciate any help that could get me playing the game.

    My dxdiag is at:

  2. #2
    Join Date
    Jul 2010
    The Netherlands
    Because of the switching I cannot see the driver for the ATI card, but the one for your Intel is outdated. I'm guessing the one for the ATI is as well.

    Please update both and try again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts