Results 1 to 9 of 9

Thread: That ol' crash problem

  1. #1

    That ol' crash problem

    Hey there. Bought BioShock for $20 on Steam, won't run now. Gets past the loading splash, and then the .exe crashes.

    Skimmed the READ THIS OH MY GOD threads, searched for some stuff like the .dll I'm having a problem with... nothing.

    Here's my details. I've heard great things about BioShock, I'd love to play it sometime in the next year.

    Problem Event Name: APPCRASH
    Application Name: bioshock.exe
    Application Version: 1.0.0.0
    Application Timestamp: 474f5a3a
    Fault Module Name: OLEAUT32.dll
    Fault Module Version: 6.1.7100.0
    Fault Module Timestamp: 49eea66f
    Exception Code: c0000005
    Exception Offset: 00004983
    OS Version: 6.1.7100.2.0.0.256.1
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

  2. #2
    Anyone? I'd really like to have this fixed and I'm frankly unsure about which direction to head in.

  3. #3
    Join Date
    Oct 2007
    Location
    Canada, eh.
    Posts
    6,289
    This Post details the information you need to provide. If you are running Windows Vista then also please see: This Post as some things such as the tablet service need to be disabled on that operating system.

  4. #4
    I am having the exact same issue. I received the same error message. Here is my PC information:

    CPU : AMD Phenom(tm) II X4 940 Processor (4 CPUs), ~3.0GHz
    Windows Version : Windows 7 Ultimate 64-bit
    Memory: 4096MB RAM
    DirectX Version : DirectX 11
    Graphics Card Name : ATI Radeon HD 4800 Series
    Graphics Card Memory : 2808 MB
    Graphics Card Driver Date & Version : 11/4/2009 09:17:30 / 8.671.0.0
    Sound Card Name: ATI HDMI Output (2- ATI High Definition Audio Device)
    Sound Card Driver Date & Version : 9/30/2009 08:34:30 / 5.00.7000.0009

  5. #5
    Join Date
    Aug 2007
    Location
    Southern Mall, Fort Frolic
    Posts
    1,827
    Yeah I just posted a thread about the same thing. I cant get past the first load screen before Im dumped out.

  6. #6
    Ok, figured it out... for me at least. I navigated to where the exe file is and set it's compatibility mode to Vista SP2. It works fine now, for me at least. I guess it's just not programmed around Win 7's OLE library yet.

  7. #7
    Join Date
    Dec 2009
    Posts
    3

    Here is how I got it to work

    I've got the 'Steam' download of BioShock. I had the same problems, this fixed it for me.

    To fix the crashing when launching the game, you need to install the OpenAL drivers.
    http://connect.creativelabs.com/open...ds/oalinst.zip

    Then, to get the in game sound to work, you need to plug in a microphone to your sound card input. Sounds crazy, but that got it working for me.

  8. #8
    Join Date
    Aug 2007
    Location
    Southern Mall, Fort Frolic
    Posts
    1,827
    I have Xp, what do you have Quakebert?

  9. #9
    Join Date
    Jan 2010
    Posts
    2

    2nd the fix

    Tried the fix above. IT DOES WORK!!

    I have a Realtek onboard audio. Downloaded the program AND plugged in something into the microphone jack and now I get sound on my Win. 7 x64 PC.

    Thanks!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •