Page 11 of 11 FirstFirst ... 91011
Results 401 to 416 of 416

Thread: Bug reports

  1. #401
    Join Date
    Dec 2010
    An enemy city is able to begin repairs of and perform ranged attacks from its encampment while I have troops in it. The encampment also has Zone of Control when on zero health and with my units inside it. The latter *may* be intended behaviour (though I doubt it - it makes little sense), the former surely isn't.

    This has a very big impact when seiging a city.

    Game version: (296277)

    Update: the ZoC isn't always there - I think it might be once the city has started repairing the encampment, though I'm not sure. It doesn't jump back up from 0 health to full, it regains a small amount of health each turn (which doesn't start immediately after me taking it).
    Last edited by mazz0; 08-19-2017 at 05:06 AM.

  2. #402
    Join Date
    Aug 2017

    [Multiplayer Bugs]

    Can't see that these have been reported already.

    World Rankings: The 'overall' state in the World Rankings panel doesn't update. At the start of the game everything is obviously zero but those numbers never move. If a save game is loaded the numbers are updated but again they stay at that level until the next reload of a saved game.

    Trade Deals: The Ai will often have a trade deal for you but when you open the deal you get the 'I cannot accept his deal'. Clicking on the 'Make this deal more equitable' recasts the deal usually completely opposite to what the deal originally was. Eg I'll give you 15 gold for that luxury and then no, wait you give me 15 gold and I'll give you nothing very much.

  3. #403
    Join Date
    Dec 2010
    I was at war with an AI player. In exchange for peace he ceded two cities to me. One of these, Carthage, was a City Sate that he must have conquered in the past. I chose to keep the city rather than liberate it, and now it is "Occupied".

    Game version: (296277)

    Update: Tried the same with a different city state captured by the enemy. Again, once given to me in a peace deal it was permanently "Occupied", so not a one off issue.
    Last edited by mazz0; 08-19-2017 at 05:05 AM.

  4. #404
    Post update a new bug has shown up any time you play team games now the scoreboard fails to update. Sometimes the scores will say 0 across the board, or just freezes on an old value. Occasionally this is fixed by lobbying the game but that does not guarantee the bug will not occur again.

  5. #405
    Join Date
    Aug 2017

    Bug when starting a new game in single player

    New single game bug: map/units not visible, turn counter rapidly increasing

    Computer configuration:

    Game settings:
    (I put max possible civs, max possible CS)

    Version and mods in use:
    (I got all official DLC including Australia. No non official mods)

    I tried twice with the same game settings, and got the same issue:
    • instead of seeing starting position, map looked undiscovered
    • no units or terrain visible.
    • bottom right said "please wait" as it does after you click "Next turn"
    • turn counter and year counter are changing rapidly (once per second if not faster)

    After changing starting position from Balanced to Standard, the game started correctly. That was the only change I made (of course, the map seed was different)

  6. #406
    So I'm playing a game in which America has taken most of Greece's cities. Greece has a great artist in the city of Sparta, presumably because she ran out of space for art in museums. When America conquered the city Sparta, the artist stayed there and many, many turns later, is still there. I launched a liberation war against America but cannot conquer/liberate Sparta because Greece's great artist is in the way. (since I'm not at war with Greece, I can't move a unit onto the same hex as the great artist).

    Save file:

    No mods in use.
    To reproduce bug, just try and use one of the melee units around Sparta to capture the city.

    I created a 2K forum account just for this bug report. If anyone knows a work around to force a great person off a hex (without going to war) or has any other constructive input, I would appreciate a direct message so it comes up in my email. Thanks.

  7. #407
    Join Date
    Sep 2017
    I encounter this

    I'm using Macbook Pro, 13 inch touch bar (late 2016). Iris Graphics 550

  8. #408
    Join Date
    Sep 2017

    Exclamation New patch on Mac with serious problems?

    After getting the latest patch by Steam autodownloaded (version says (153264); Mac), I get all my units on the map with an auto-selected route to somewhere down in the lower right corner of the map. All the informations popping up on the right have their icons changed to a !. And the game seems abysmally slow.

    DLC: Aztec Civ Pack
    Moar Units
    New Wonders
    Yet (not) Another Maps Pack

    - disabling seems to have no effect.

    Link to save file and screenshots:

  9. #409
    Join Date
    Oct 2010
    Quote Originally Posted by Riding_Digital View Post
    BUG: The game freezes every time I exit to Windows from within a game. Running top spec PC with Windows 10 x64. Play multiplayer with a friend who has the same issue every time. Annoying because I cant access task manager so only way to exit is to hard restart/power off PC. I've seen some other threads dating back to Oct 2016 on other forums but still no patch? seems a pretty big issue. Thanks
    I often have the same problem, Windows 10, 16GB Ram, GTX1070. I find I can play for about an hour and exit without a problem, but if I play for a longer time my screen will freeze on exit. Using Task manager will work if you open it earlier and under Options select 'Always on Top', otherwise a restart is required.

  10. #410
    I'm sorry if some of these have been included in the past but after coming back to the game for a while after the latest update, I have noticed a few things:

    Always play huge map with 12/13 civs & 15 city states. These issues are across multiple games played.

    1. Pearls and Whales no longer show up on map in any game I play. Other luxuries are always spawned very limited i.e. wines, incense, and truffles. Others are overly abundant. spices, citrus, and silks. I have 31 sources of citrus.
    2. Scientific City States do not all...
    3. Zanzibar City State never generates. Is CS generation at game launch random?
    4. Especially on Huge Map...Most Civs clustered together with one or two by themselves with lots of land to explore and create HUGE empires. Last game (will post) half of the map for the first 500 turns was not settled.
    5. Oil is almost non-existent and there is no oil on coastal tiles. I believe on this HUGE map there is 5 or 6 sources of oil. Iron and Niter are limited. Aluminum and Uranium is wildly abundant.
    6. Game(s) launches with 12 or 13 Civs. Always 1 or 2 does not spawn. (Or is immediately killed by Barbs?)
    7. Launch Fractal map get one large Pangea.
    8. Settler and Worker progress is slooooow (15 - 25 turns). AI is popping them out like hotcakes.
    9. Constantly asked by AI to trade writings, paintings, and music. Offers me a deal: Luxuries, GPT, open boarders. Game will not allow me to accept. It says Refuse or Make this deal more equal (you know). I click on more equal. Then the deal becomes my cultural item, a HUGE GPT I must give them, open boarders for their horses. WHAT?

    No mods. No map editing.

  11. #411
    Join Date
    Oct 2017
    I haven't played since June until today, so I'm not sure how many updates there was mashed into one, but something in my update has caused the speech from foreign leaders to start off the screen in a single line. If there's a line break it's fine, but any paragraphs are lost.

  12. #412
    Government 'legacy bonuses' is or may be not working correctly. I will see legacy bonuses listed for government types I have never been. For example; earning/gaining a % discount on gold purchases for Merchant Republic even though I have never been a Merchant Republic .

  13. #413
    Join Date
    Feb 2015
    Post Fall Patch.
    No Mods Installed.
    Fresh Reinstall, after deleting all Civ Folders in Steam/Steamapps/Common and in Documents Folder. After a restart.

    Game crashed on turn 150 on Marathon Speed, playing on Dx12 Version. Latest Drivers installed on R470 8gb + Latest HD Sound drivers. Auto Crash Report Sent.

    Sound is breaking on units. - No combat sounds.

    Animations and Effects are breaking on units. - No flashes from cannonfire or battleship.

    Sentry no longer works. - Units remain in sleep mode/Sentry, they do not wake up to enemy ai civ units or barbs approaching.

    System - Ryzen 1600x, 32 gb Ram, R470 8gb Gpu.
    Would seriously suggest you rethink your use of old builds to update in patches. This is why bugs like sentry aren't working anymore.

    Current Game, Crashed on turns 265, 277 and now again on 452. Seems to be connected with trying to scroll the map whilst turn starting. Doesn't act like a normal crash, the game just CTD's. Instantly Exits.. Better than trying to exit the game. Maybe this is the new workaround for that crash bug.
    Last edited by Goliht; 3 Days Ago at 10:04 AM.

  14. #414
    Join Date
    Oct 2017
    Alexander is getting war weariness when he shouldn't be.

    Last edited by Lunzatis; 2 Days Ago at 11:48 AM. Reason: Additional Image

  15. #415
    Join Date
    Nov 2016
    When advisor tips are on and you re-load a game, the game goes through and displays all the advisor tips you have seen so far once more even though you have previously clicked OK to dismiss all those tips before. This happens every time you re-load a game.

    This didn't happen before. I think this bug was introduced a couple of patches ago.

  16. #416
    Join Date
    Oct 2017
    Description of occurrence:
    Cities trading seems to be broken.
    Traded cities not originally belonging to the civilization with which the deal is done remain in occupied mode permanently.

    Some topics about that :

    Mods in use:
    No mod, only official civilisations DLCs are installed. The bug was already existing before the Fall 2017 update, the update doesn't fix it.

Page 11 of 11 FirstFirst ... 91011

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts