Results 1 to 2 of 2

Thread: [Gameplay] Game Freezes or Crashes on Barbarian Turn

  1. #1
    Join Date
    Jul 2017
    Posts
    1

    [Gameplay] Game Freezes or Crashes on Barbarian Turn

    Hi,

    I've been playing Civ for a while and really love the game, but since getting my new computer and updating my nvidia Drivers I have been having consistent crashes and game freezes when playing Civ. This Error will occur on the barbarian turn of the game where the game will display the 'processing turn for barbarians', but will never finish processing. The cursor will play the loading animation and the music will continue playing, but everything else will freeze, leaving me unable to interact with the game or even access other applications or switch tabs. When that happens, i have no choice but to force restart my computer.

    The freeze can happen on any barbarian turn at any point in the game, and sometimes the game will manage to process a barbarian turn that previously it crashed on if i try enough times. Mostly however, the crashes happen every 20 or so turns in the early game, drop off in the mid game and start increasing to every 4-5 turns by about the modern era , to the point where i am unable to continue the match because the game crashes on the turn i am loading at. Any help you guys can give would be appreciated, cause i would like to play but its getting very frustrating having to constantly reload from autosaves and hope it doesnt crash again.

    My DxDiag is at this link: https://pastebin.com/BEq2CtVJ

    Thank you for your help!

  2. #2
    Yeah, I'm having the same problem. Last year I bought a new PC with the following specs: i7 4790k (4ghz), 16gb of ram and a GTX1070 graphics card. I still use windows 7 64bit, the same OS as my last PC. However my game constantly crashes (every 4 or 5 turns) in the beginning. Near modern era the game will eventually crash on the barbarian turn and I wont be able to continue it, even after reloading. I've tried reinstalling the game, playing with no mods, updating my drivers, even playing with headphones (I read somewhere that Nvidia digital audio makes it crash more often). Nothing helped me. I gave up Civ 5 for good. Because every single game will crash for good at Modern Era. There is no fix, as far as i can tell. If you find some fix, please tell me, because this is the only game I still care for playing, and some players on youtube don't seem to have any problem with it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •