Hello Everyone -

The fix for me is to go into GeForce Experience > Settings ("gear" icon) > General tab > IN-GAME OVERLAY (set to off).

This is late news, but hopefully good news nonetheless.

In case anyone has out of date GeForce Experience, the "IN-GAME OVERLAY" was previously referred to as "SHARE" and before this, it was called "SHADOWPLAY", so look for any of these names in the GeForce Experience settings and turn it off. This is also the culprit of various issues in several other games.

Before realizing this, I had tried all or most of the items on the usual list of solutions that other people have tried and suggested on various forums over the years.

I hope this helps!

Jealot